Multiplayer connection problem

  • Problem Description

    Me and my friend cannot connect to each other on any multiplayer examples. I'm using Firefox, he is using Chrome, but it seems that with any combination of browsers it still doesn't work. The first person to connect (the host) doesn't have any problems, but the second person to connect (the peer) appears to join, but cannot see the host in the player list and their messages aren't seen by the host. After a few seconds the log writes "Kicked (either couldn't connect to host or host left".

    Attach a Capx

    Default Multiplayer Chat Example.

    Description of Capx

    Just a multiplayer chat room made by Scirra.

    Steps to Reproduce Bug

    • Step 1 - Log in to the chat room as host normally.
    • Step 2 - Log in to the chat room as peer.
    • Step 3 - Peer gets kicked after a few seconds.

    Observed Result

    Peer gets kicked out, even though there shouldn't be any problems connecting, and the second person sees that there is already a host as the log says: "Connected as peer". However, the peer doesn't see the host, cannot send messages to the host and in a few seconds gets kicked.

    Expected Result

    Connection shouldn't have any problems and the host and peer should see each other and be able to send messages to each other.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: Not Tested

    Operating System and Service Pack

    Both use Windows 32

    Construct 2 Version ID

    Construct 2 - 206

  • Hi Niker107 Did you tried it on your system first with 2 browser in lan preview mode? does it works fine?

  • Yes, I have. It works fine with two instances of myself, and it works fine for him with two instances of himself as well, but the two of us can't connect to each other.

  • Okay. Are you both in same network while testing with each other? Because I just tested and its working at my end.

  • Ehm, no, we live in different countries. But I assumed that that shouldn't make a difference? Multiplayer shouldn't be constricted to only people living in the same house or just on the same network, as far as I know.

  • I tested it with a friend from the same country and city, and it still doesn't work. It kicks him, saying that he couldn't establish a connection to the host or the host quit.

  • Niker107 Could you share with me the link so I can test it with you?

  • There, I uploaded a modified version of the chat example (I changed the instance name) to Google Drive. Here's the link:

    googledrive.com/host/0B0_TJqqpyZ0Qfk1FcmMwWmlsd1R3ek5kY3BXem5CRXo4LVh2RDNnaDBNNm9pOVg4X2JsR0E/index.html

  • Gotta go to sleep now, had to close down the link. If you see you've joined as a host without problem, that means I'm already gone.

  • Niker107 Try it with my files. Mine seem to work. https://www.dropbox.com/s/mdb5n4rsm96tz ... e.zip?dl=0

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as not a bug. This is a network connectivity issue, not a Construct 2 bug. One of you probably has NAT which blocks the connection. The multiplayer tutorial covers this briefly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)