Mac Node-Webkit can't display text of +6000px

0 favourites
  • 11 posts
From the Asset Store
Change delay, create new lines, "backspace" the text
  • Problem Description

    When I export to mac a project that has a text with height larger than +8000, it just shows a black box. This doesn't happen on Windows or during testing in Chrome.

    Attach a Capx ... RKING.capx

    Description of Capx

    Just shows a project with a textbox bigger than around 8000. When exported to Node-Webkit for Mac, it shows only a black box where the text should be.

    Note: I had the same problem with 8000+ height in mac, but then I used minimise, and it managed to overcome that limit, and 8000 + started to be the new limit.

    Steps to Reproduce Bug

    • Open capx
    • Export to node webkit
    • Open with OSX

    Observed Result

    Black box instead of text

    Expected Result

    .app exported project to show the text, not a black box

    Affected Browsers

    • Chrome: (NO)
    • OSX: (YES)
    • Windows: (NO)

    Operating System and Service Pack

    Windows 7 SP3

    Construct 2 Version ID


    EDIT: Found that it doesn't work for +6000 too

  • Closing: you're probably exceeding the hardware maximum texture size (commonly 2048, 4096, 8192 or 16384, depending on the machine). Why on earth do you need such an extraordinarily huge text object? It's easy to work around anyway, just break it up in to several objects.

  • This is present in Mac only, not in Chrome, not in webkit for PC, iPad, CocoonJS.

    It's a very minimal and elegant solution to the problem, that's why it's the best way to go. I'm quite aware of the alternatives

    Thank you

  • It's on cocoonJS and Ejecta too. The same problem there.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I haven't tried it out on Android. I'm trying to find a workaround to this, but nothing seems to work.

    I tried scaling the spritefont or text layer, just that layer, and making the original text smaller, so when scaled, it reaches 4096, but it's zoomed in.. still didn't work unfortunately.

    It doesn't work on Ejecta and CocoonJS... ipad mini is not affected, but ipad air is, so is iphone 5s.. it's strange.

  • This can't be fixed, you try text with size more than 6000, every device has it's own max texture size (like iphone 5s no more than 4096). And, as i know, cocoonjs and ejecta can work only with no more than 4096 texture size.

  • Here's the screenshot from cocoonjs debug to prove my words.

  • My hands are utterly tied here. I can't use text object since the limit on 4096 height, and I can't use sprite font which works perfectly on Mac PC, but framerate is instantly terrible on mobile for bigger texts.

  • Thanks anyway I feel like I can understand your struggle with the rock here

  • Thanks anyway I feel like I can understand your struggle with the rock here

    As Ashley said, cut your text into peaces, or create a text(maybe spritefont) 500-600 size, and set it via events, this is the best and the only solution for ya

  • Spritefont lags on mobile if it's even more than 500... I'd use spritefont since it doesn't have size limit, other than the lag

    I want to cut it, but I can't determine which text how much it takes up, to automatically set it up. It's a large visual interactive novel, and has LOTS of chapters. Cutting it up would be a long arduous process. I'd rather find someone that could make a non-texturesize increase zoom function for text objects, so I can just zoom in a smaller version of the textobject, than cut it up manually

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)