Can no longer open project after upgrading to r180

  • Problem Description

    I tried upgrading to the r180 beta and got this message when I tried to open a project I've had in r178: "The project you are opening uses a newer version of Text box 1.1 (installed plugin is version" After I press okay to load it anyway, I got a "Cannot find condition by ID" error, so it won't open. I tried downgrading to r178, but the error is still here. I have the advanced textbox plugin installed, so I'm not sure if that's a culprit or not. Any ideas? My project is currently in .caproj form.

    Attach a Capx

    I can't upload a Capx because I can't open my project

    Description of Capx

    It's a drawing game that utilizes textboxes for user input

    Steps to Reproduce Bug

    Not quite sure, but probably something like this?

    • Install advanced textbox plugin on r178 and create a project using the On Focus Gained condition
    • Upgrade to r180

    Observed Result

    Will not open due to downgraded Textbox plugin

    Expected Result

    The project opens

    Affected Browsers

    N/A

    Operating System and Service Pack

    Windows 7 64 bit

    Construct 2 Version ID

    r178/r180

  • Closing, we cannot support third party plugins. This error is caused by the "advanced textbox plugin".

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If anyone else is having this problem, it was due to me downloading a replacement for the standard textbox. Each new installation will wipe out any customizations to the standard plugins with Construct 2 (rightfully so) and that makes conflicts like this happen. After switching over to advanced textbox instead of a hacked textbox, everything works now

  • gizmodude4 - where did you get this plugin exactly? If it uses the same ID as the official textbox plugin I want to make sure it's de-listed from the forum, since that's a terrible idea and is just going to cause horrible compatibility problems for whoever uses it. The plugin author *must* use a different plugin ID.

  • I found it here:

    I probably should have known better than to download a two year old plugin

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)