Local Storage not working in FireFox

  • Problem Description

    I need to use the local storage plugin in FireFox, but I keep getting the error message:

    Javascript error!

    InvalidStateError

    http://localhost:50000/LocalStorage_plugin.js, line 13 (col 0)

    It works fine however in NW.js and Chrome preview

    Attach a Capx

    https://drive.google.com/file/d/0B1n4Fd ... sp=sharing

    Description of Capx

    This capx allows you to clear storage with pressing "1". By pressing "2" you write two highscore files. Press F1 to restart the layout and see that the values have been loaded in and printed on the text objects.

    Steps to Reproduce Bug

      Simply boot the capx in firefox preview. Nothing works.

    Observed Result

    I preview the capx in firefox and immediately get the error. The capx however works fine in Chrome and NW.js

    Expected Result

    I expect the local storage to successfully store the files and load them.

    Affected Browsers

    • Chrome: (NO)
    • FireFox: (YES)
    • Internet Explorer: (NO)

    Operating System and Service Pack

    Windows 7 64 bit 6.1 build 7601

    Construct 2 Version ID

    r206 64-bit

  • have you found a solution? i have the same problem

  • As far as I can tell, this is a Firefox bug. It's simply failing to open storage at all. Does it still reproduce if you create a new Firefox profile?

  • I have the same problem, my games are "broken" since I use LocalStorage instead of WebStorage. :/

    It doesn't affect all my Firefox users, but it doesn't appear to be a "version" thing either, some have the latest version 39-40 just like me, I don't have this bug, they have it.

    How do we create a new Firefox profile?

    Thanks!

  • Ashley Making a new profile actually fixed the bug. Thanks!

    This one's made me unable to work on my game period.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • WebStorage was much better for me also. Only problems with localstorage

  • Not sure whether this should go down as a separate bug, but I've noticed that "getting" even a single local storage item on Safari browser on some iOS devices (specifically iPad 2 and iPad mini 2) can take a loooong time, sometimes up to about 10 seconds.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)