Load image from Web: Sprite and Tiled Background

  • Link to .capx file:

    CAPX: dl.dropboxusercontent.com/u/111483211/bugLoadSpriteFromWeb.capx

    PHP Source: dl.dropboxusercontent.com/u/111483211/bugLoadSpriteFromWeb.php

    Screenshot: dl.dropboxusercontent.com/u/111483211/ScreenShotBySeryiza-2014-02-06%2020_06_38.png

    Steps to reproduce:

    1. Create some Sprite objects

    2. Create some objects Tiled Background

    3. Set to each instance action "Load image from Web"

    Observed result:

    Sprites do not pick separately.

    Expected result:

    Sprites do pick separately.

    Browsers affected:

    Chrome: yes

    Operating system & service pack:

    Windows 8

    Construct 2 version:

    r158.2

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Link

    Not a bug. This is a Sprite's object specific. You must load to different frames. And you don't need "for each" action

  • I'm afraid it's currently by design.

  • Hi. Seems I encountered the same problem here:

    So a for-loop picking separate instances of a sprite will not work and even if you pick a single instance all sprites will load the new image, right?

    I tried to load external images for all sprites so the user can customize it.

    Is it possible to add new frames on runtime and load a different image for all frames for a sprite object and then set the shown frame for each object?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)