List Object Positioning Bug

  • Link to .capx file (required!):

    dropbox.com/s/ylt3frjzi0mxoo7/listboxbug.capx

    Steps to reproduce:

    1. Create a list object in the top left or top right corner of a layout/window.

    2. Preview in browser.

    3. Export to webpage.

    Observed result:

    Box at top left [0,0] disappears off screen in preview in browser, top right is ok. Upon export and upload to server, top left box is seen far to the left of the layout and top right box is shifted from its expected position.

    Expected result:

    List boxes should appear in locations as placed in construct preview.

    Live at mbcoffice.com/construct/listboxbug

    Screenshot (Chrome version, IE and Firefox same result):

    <img src="http://www.mbcoffice.com/construct/listboxbug/chromeactual.png" border="0" />

    They grey boxes are a sprite/screenshot/background of where they should be according to construct preview.

    The following is how it looks with preview in each browser:

    <img src="http://www.mbcoffice.com/construct/listboxbug/previewlists.gif" border="0" />

    Each browser is pretty accurate when previewing (Firefox does the best), but they are all missing that top left list.

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Windows 7 Home SP1

    Construct 2 version:

    R119/64bit Steam

  • Did you try r120.2? We already published a fix for this.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I did not, didn't think to look in the beta. Sorry!

    Glad to hear it was already fixed :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)