[Linux] problems with particles

  • Link to .capx file (required!):

    Capx: dl.dropboxusercontent.com/u/40173010/LinuxFS_Part.capx

    Everything is perfectly fine in Windows 8/7.

    But when trying to run the project on Ubuntu 13.10, all particles of the game are not performed correctly, I created a completely new project (the capx above), and the same error happens.

    From what I observed, does not happen any performance problem, drop fps, anything, everything is fine, but the particles are presented with problems, sometimes larger and without the correct images.

    I put two screenshots below which shows what happens.

    note: sorry my english :D

    Steps to reproduce:

    1. Create any particles in the project

    2. And try to run the project in Ubuntu 13:10

    UBUNUTU TERMINAL LOG

    ./newproject

    [3019:1025/180455:INFO:gpu_info_collector_x11.cc(80)] NVCtrl extension does not exist.

    [3019:1025/180455:INFO:CONSOLE(9)] "Viewport target-densitydpi is not supported.", source: file:///tmp/.org.chromium.Chromium.inNgEo/index.html (9)

    ATTENTION: default value of option force_s3tc_enable overridden by environment.

    Observed result:

    Runing on Ubuntu 13.04

    i.imgur.com/MHxHDGs.png

    Expected result:

    Runing Windows 8

    i.imgur.com/Jm8vbY7.png

    Affected:

    Node Webkit

    Operating system & service pack:

    Ubuntu 13.04

    Construct 2 version:

    148

  • Are you sure this is not a problem with the graphics driver on Ubuntu? Linux graphics drivers can be especially problematic, and if it works on all other systems, that would suggest Construct 2's code is correct.

  • Ashley It's funny, but I ran the executable version of the Windows in Ubuntu 13.10 using Wine 1.4, and particles work perfectly.

    But the specific version of the Node for Linux, works with some problems :D

    I also tried using the latest version of node-webkit-v0.8.0-rc1-linux-ia32, but the same problem happens.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Sounds exactly like a graphics card driver rather than a C2 bug, so closing.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)