LAN Preview - Unable to start HTTP server (IP)

0 favourites
  • 5 posts
From the Asset Store
The official Scirra Multiplayer Signalling Server for helping peers find and connect to each other
  • Problem Description

    While it was working fine for the last year or so, I now always get an error message saying [quote:eo710i9d]Unable to start HTTP server on '' port 50000(1232). You may need to restart Construct 2 with Administrator privileges. Construct 2 will attempt to start the server on 'localhost' instead.

    Running as 'localhost' then works fine. (But is not what i need)

    • I'm running C2 as Administrator
    • firewall is turned off completely (even though ports were opened in config correctly)
    • running on 'Personal Licence'
    • Nothing else is using a port in that range
    • If 1232 is a PID, it is not in use either
    • network IP is correct and static
    • there are no other http servers active on that machine/IP.

    Observed Result

    LAN Preview HTTP does not start when using Lan IP

    Expected Result

    LAN Preview HTTP should start.

    Operating System and Service Pack

    Windows 10 Home

    Construct 2 Version ID

    r221 stable - r226 beta

  • The error code 1232 is "ERROR_HOST_UNREACHABLE - The network location cannot be reached." according to MSDN, so it sounds like maybe the IP is wrong, or something else is running as a server on your system and causing a conflict, or network permissions changed or something. Either way we haven't changed the code around this for a long time, and nobody else is reporting problems, so it seems likely the problem is with the network configuration on your machine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • hil

    You solved this problem?

  • I have exactly the same problem. Which is:

    • I'm running C2 as Administrator
    • firewall is turned off
    • other servers CAN be started on the same port and IP (for example HTTP server of TortoiseHG does that)
    • local IP address pings succesfully

    And even though I can see other servers work on port 50000 I still get 1232 error from Construct.

    This is a complete mistery. And considering that I can make other HTTP server work on the same port and IP, it has to be a bug in Construct logic. I mean it works, I can see it. So why doesn't it work?

    What I don't understand is why to check if the server is reachable at all? We do not want to do anything with a remote server, so it doesn't matter if it is reachable. Apparently there are some cases in Windows when a local server is considered unreachable.

    I don't know if it helps, but when I type "arp -a" my IP is not on the list. But I can still ping it and run an HTTP server on it.

    I'm really out of ideas how to fix the problem. Either I have to make my IP reachable or there must be some change in Construct.

  • I am having the exact same problem. I see another person is saying that he is having the same problem, So since there is more than one person having the exact same problem in just this post, how many people are posting this problem in other posts. It isn't a problem with our computers.

    This needs to get fixed, it is really annoying.

    And NO I am NOT using the free version.

    I am using the PAID version and it is not working the way it should.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)