Invoke Download not working properly

  • Problem Description

    Invoke Download works locally in "Run Layout," but does not work when live on a web page. It appears to be behaving as "Open URL in New Window" instead.

    Attach a Capx

    http://thekidzpage.com/notworking/wontinvokedownload.capx

    *This is the example .capx included with Construct 2 (aka: Example: Taking screenshots)

    Description of Capx

    Take screenshot then invoke download.

    Steps to Reproduce Bug

    • Click/Tap Button: "Take screenshot"
    • Click/Tap Button: Download

    Observed Result

    Image opens in new window (as in "Open URL in New Window" command, rather than the "Invoke Download" command as specified) No error message is present.

    Expected Result

    Dialogue box opens to request download location for image to save

    Affected Browsers

    • Chrome: YES
    • FireFox: YES
    • Internet Explorer: YES
    • Opera: YES

    Operating System and Service Pack

    Windows 7, Service Pack 1

    Construct 2 Version ID

    Construct Release 163

    *Also tested on and affects: Chrome and Safari using iPad Mini

    Live Demo

    http://thekidzpage.com/notworking/

  • IMHO , even if it is open in a new url under the name "data:" you can click right and save picture as.

  • Thanks for your feedback, Naji However, it's a feature that was present and working in previous versions and I already use it in my games, so I'd prefer that the bug be fixed rather than ignored.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Looks like the minifier broke the feature detection (opening a new window is a workaround for browsers without invoke download support). Fixed for the next build; workaround in the mean time is to disable minification on export.

  • Thanks Ashley. Great news

  • Hello.

    Sorry to unearth this topic but I have the same problem but with IE only (tested on version 11 on 2 computers).

    It opens in base64 in a new tab. It does not offer the download.

  • Hello.

    Sorry to unearth this topic but I have the same problem but with IE only (tested on version 11 on 2 computers).

    It opens in base64 in a new tab. It does not offer the download.

    christ59

    As it states in the sticky, you should not be posting in a closed bug report, especially one from 4 years ago.

    Either create a new bug report, following ALL of the Bug Report Requirements, or maybe ask for help in the 'How Do I' section.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)