Intel XDK - Plugin failed to install

  • Problem Description

    The Intel XDK build fail if you try to use:

    Plugin ID: com.cranberrygame.phonegap.plugin.ad.admob

    Steps to Reproduce Bug

    • Add the plugin to your XDK project
    • Try to build it
    • It fails

    Observed Result

    Error: Plugin failed to install: com.mcm.plugins.androidinappbilling (com.mcm.plugins.androidinappbilling)

    Operating System and Service Pack

    Windows 8.1

    Construct 2 Version ID

    R193

  • We can't fix issues with the Intel XDK, it's developed by Intel - please report this issue to them.

  • Noooooooooooo... I have to go back to PhoneGapIAP for Android again

    I thought I can use this Plugin for both Windows and Android

  • I have reported this issue on the Intel XDK Forum

    https://forums.html5dev-software.intel. ... 34&t=10692

    Hopefully someone will respond. IntelRobert, are you from IntelXDK team? Can you please look into thisi issue?

  • SamRock I have talked with Cranberrygame about this. This is not a problem with the Intel XDK, its a problem with the IAP official plugin. Now I'm using Cranberrygame IAP plugin and that problem is gone.

    I would like the most to stay close to the official plugins but I don't know what to do.

  • Iolva & Ashley,

    Looks like we found a fix for this issue!!

    I have written a short article(not really short) for the benefit of the entire C2 community!!

    https://www.scirra.com/tutorials/1376/f ... iap-plugin

    Ashley

    Looks like IAP plugin, has to reference these files in Intel XDK XMLs

    Can the exported C2 project include reference to the files I mentioned in my article?

  • Ashley - that's not a plugin we maintain, there are very few we do, and they are all com.intel.*

    Can someone post the full build log of what the error is when using the C2 default IAP and the Admob plugin? We'll try to see if it's a bug in the plugin or both plugins requiring a common file (like android-support-v4.jar)

  • Ashley - that's not a plugin we maintain, there are very few we do, and they are all com.intel.*

    Can someone post the full build log of what the error is when using the C2 default IAP and the Admob plugin? We'll try to see if it's a bug in the plugin or both plugins requiring a common file (like android-support-v4.jar)

    Wow, you are from Intel!!? Nice to see you on the C2 forum!!

    As for the Build log, we only get the log that Lolva has share in the OP screenshot.

    I didnt see this issue with Admob Plugin.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Looking at her message, there was a failure to download the plugin. It could have been moved from the Cordova registry, or Github had a hiccup. I will try to look into this more.

  • Hi Iolva,

    I know this is a closed thread. But can you tell me if you are able re-purchase "consumable" products using the PoneGapIAP (by cranberriesgame)? ALso does that plugin show you the prices for each product?

  • SamRock

    I haven't include any "comsumable" products on any on my game, so I'm not sure about that :/

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)