Input-Buttons/-Textboxes invisible in mobile app Intel XDK

  • CAPX file

    --> attachments

    Problem Description

    All the input objects, e.g. buttons, are not working correctly on the mobile version of Intel XDK, neither in the app preview or in a compiled app.

    Steps to Reproduce Bug

    • Create a construct2 project containing some input objects
    • Export to Cordova
    • Import in Intel XDK
    • Compile it or just test it using the preview app

    Observed Result

    In the PC's web browser it's working correctly - the same thing happens in the XDK's emulator.

    But the bug happens in the mobile version.

    The input objects are not shown in any form, styling them using CSS does not help either.

    But there are two strange things:

    First, the object exists (Android's keyboard-emulator is loaded, USB keyboard is also working) and you can enter text, but you do not see anything, except ...

    The second thing is that the cursor is still there, and through the display magnifier, that is always shown when moving the cursor, you can see the input-objects (but the pages background-color is black instead of white).

    Expected Result

    The input should work correctly like in the web browser.

    Affected Browsers

    • Chrome: (NO)
    • FireFox: (NO)
    • Internet Explorer: (NO)

    Operating System and Service Pack

    Windows 8.1 Pro Update 1 (December 2014 image, so-called Update 3) 64 bit

    Android 4.3 Jelly-Bean (Sony-Build)

    Construct 2 Version ID

    R195 (x86)

    Additional Notes

    Maybe this bug is not caused by Construct 2, but in this case someone could think about a workaround.

    This is working correctly, when I add it to the HTML code: <input type="text" />

  • Hi

    Did you come up with a solution ?

    Mine is still here

    Cheers

  • i have the same problem actually under android

  • Can't reproduce here: on a Nexus 9 running Android 5 and the latest XDK/Crosswalk, all form controls appear correctly and can be interacted with. I tested text boxes, dropdown lists, list boxes, and buttons.

    Have you tried using the latest version of Crosswalk? How about the latest beta?

  • Thanks for the CAPX file. I will test this in the XDK/Crosswalk today.

  • I tested on a Galaxy S3 using the Debug tab (based off Crosswalk) and I could see the input boxes fine. Any one else seeing this issue? can you provide the device and OS?

  • A quick (semi-related) question.

    Is the Android keyboard supported?

    I didn't use Construct 2 for a few months but at version 170 the keyboard couldn't be used from Android.

    Is this changed? Does a textbox trigger the Android keyboard these days?

  • I have a very similar issue with frames of sprites that I populate with C2's 'load image from URL'.

    The sprite shows the frames no problem in C2 preview and the XDK simulator, but on my Galaxy S2 Android 4.1.2 or Nexus 10 Android 5.0.1 I merely get a black rectangle.

    The twist that baffles me is that my game logic later does maths on those frames and their dimensions and populates a data dictionary with values. All that logic takes place and I can verify that the values are measured correctly based on knowing the image that was loaded into the frame.

    It's as if the final hurdle of drawing the image fails. I thought it was perhaps an issue with the browser that wraps round my build (is that what Chromium is?) but maybe its further upstream ?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi,

    I Have exactly the same problem. I use Construct 2 version 198 and Intel XDK 1878. On a Samsung Dous device(android 4.0.4) when a text box got the focus its text goes disappear! How could I solve this problem?

    Another problem, I want to attach my .capx file but I cant find any tool here to attach my file.

  • Tested again using newest XDK and c2-v200.

    Bug is still there.

  • Bump, having this issue on kindle fire.

  • Anyone figure out how to fix this?

  • Closing as original issue is over a year old and unlikely to be related - I think some time after the original post an XDK update fixed it. Please file a new report following all the guidelines if you still have trouble.

  • Hi I'm having the same issue, when I export to cordova the buttons and text inputs get invisible on mobile device, I have made the probe in android 5 and the controls show well, but when using on android android 4.1 the controls are invisible, also the video plugin works only in android 5, in android 4 doesnt show video

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)