Image Editor Not Open, Yet Says Its Open. Cant Edit My Files

0 favourites
  • 6 posts
From the Asset Store
Human/Character Base Pixel Art Sprites in various poses (nearly 100 files)
  • Problem Description

    When I launch C2 (I even updated off of Stable to the newest Beta) and I make a new project or open an existing, it seems to think the Image Editor is open, which prohibits me from doing anything.

    Can't add events, edit sprites, nothing! I can't even exit out of the program without having to use Task Manager!

    Attach a Capx

    None to replicate!

    Description of Capx


    Steps to Reproduce Bug

    Literally all I do is open C2 and nothing pops up, but when I go to click it says "Oops! There is a image editor already open. Make sure it is closed before you try to open another one.".

    Which is weird because again, no image editor is open and this happens when I click on anything, adding an event or double-clicking a sprite.

    Observed Result

    It wont' let me work! This pop up blocks the C2 editor entirely.

    Expected Result

    The image editor to work!

    Operating System and Service Pack

    Windows 10 Pro

    Construct 2 Version ID

    Construct 2 Beta release r231 but this was also happening on stable r227.

    You can view a screenshot of the issue happening here. If the problem persists and there is no immediate fix, I will make a video to demonstrate! ... rIssue.png

  • Hello,

    Have you tried 'File/Prefs/Reset dialogs'? ()

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah this does fix it you're right! I completely spaced on that. Still though quite the annoying bug!

  • That's weird, I have been using C2 for 3 1/2 years but never encountered this.

  • Closing as there is nothing we can do to resolve this without the steps to reproduce the problem in the first place.

  • Hello,

    Have you tried 'File/Prefs/Reset dialogs'? ()

    im having the same problem but how do i go to File/Prefs/Reset dialogs?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)