Glitchy preview

  • Problem Description

    For as long as I can remember the Preview function of Construct 2 has been very glitchy. In my experience it'll only react to you clicking on the preview button 1 time out of 5, and in 90% of cases it opens a new game tab instead of updating the already existing one.

    Sometimes it opens the wrong browser - especially if you have preview tabs already open in multiple browsers - and sometimes you have to frantically spam F5 or the preview button in order to get the preview to launch at all.

    Attach a Capx

    None needed.

    Description of Capx

    None.

    Steps to Reproduce Bug

    • Download Construct 2 on Windows 7 or 8 64-bit.
    • Start a new project - or even better - open an already existing one.
    • Run preview by clicking on the preview button.

    Observed Result

    Preview doesn't launch properly and when it does run at all, focus is rarely switched over to the browser.

    Expected Result

    For preview to launch immediately upon pressing F5 or the preview button, and for window focus to switch over from Construct 2 to the browser tab where the preview is running, whether it's a new tab or an already existing one.

    Affected Browsers

    • Chrome: YES
    • FireFox: YES
    • Internet Explorer: YES

    Operating System and Service Pack

    Windows 8.1 64-bit, Windows 7 Ultimate 64-bit. All possible updates installed.

    Construct 2 Version ID

    200, but I have experienced this problem for as long as I can remember.

  • I have never had this problem... ever.

  • Yes, it's understood that bugs don't necessarily affect everybody.

  • I can't reproduce by following your steps, so there is very little I can do to investigate this. Have you tried the latest beta r205 as well?

  • i' ve had this happen too, but became customed to repeating preview, i figured its some kind connection with the last preview that gets lost somehow, its pretty much random but less on fresh start, but i do have it a lot when working for a while

  • I had this problem, too.

  • Can anyone still reproduce this in r206?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as no further reports since r206. Please post a new issue if you still have problems.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)