Games won't open.

0 favourites
From the Asset Store
Alot of high quality cartoon sound effects for your game! :D
  • This isn't a bug, but, wasn't sure where else to post this.

    I've started the beginners tutorial and nothing seems to run even if I try the example files they won't play. I have tried it with firefox 10 and iexplorer. I Even updated firefox to 11.0 and have the same issue.

    When I hit play a browser pops up and I see as the URL, and eventually it times out. I tried turning off my firewall and still have the same issue.

    I'm using a windows 7 pc and as I mentioned now I am using firefox version 11.0.

    Anyone have any idea how to get past this?

  • Are you sure there are no other servers running on your computer that block Construct 2's server? Does changing the preview port in Preferences help? Does it work if you enable the Preview-on-LAN feature but just run locally?

  • Thanks for the reply.

    I have tried to change the server to 50100, turned off my antivirus, and am only running one version of iexplorer and firefox. I've closed most other programs in task manager.

    I have also tried to run in admin mode with no effect. The preview on lan feature is greyed out for me because I have a free version.


    One last thing I run through a router, but, my brother has no issue on his pc, so it shouldn't be a router issue.

  • zenprophet I'm afraid I'm not sure what the problem could be - it may be your computer's configuration, or there may be some way to work around it in C2, but it's hard to tell. Perhaps as a last resort you could try setting the Preview Mode in Project Properties to 'File'. This skips the server entirely and just loads a file on disk, but modern browsers have such strict security limitations on files on disk often they just won't run. For that reason we have the feature deprecated since we hope to remove it, but it might give you at least something to work with for the time being.

  • Thanks for the reply Ashley.

    Setting project properties to file worked. I'll download a fresh copy of chrome and will not import any settings and just let it do a default install. If I find the answer in my browser settings I'll post it here or somewhere else for others that might run into this issue.

    Thanks again.

  • Update.

    I downloaded chrome and tried it out, but, I get an error that it can't launch chrome. I tested with opera, firefox, ie, chrome again with no luck. However if I paste "localhost:50100" into an opera browser it works fine.

    The game doesn't launch, but, if I put localhost:50100 in the address bar I can preview my games in opera.

  • I had the same problem in my girlfriend's notebook during the Global Game Jam this year. It was a brand new Asus N53S. I tried everything and couldn't get it to work. In the end we used the file preview as a last resort.

  • 7 premium ?

  • Sorry for the slow response. Yes windows 7 premium is the os I'm using. Seems to work fine in opera, but, it won't open up a tab or browser I have to have opera up already and paste in localhost:50100. But, it's working for me this way.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • 7 premium ?es, Win7 Premium indeed. What`s wrong with it?

  • Well considering that the webserver for preview is a service from windows itself, probably that win7 premium doesn't "serve" correctly this service or something.

    I don't know exactly, but it may be due to one of the "limitations"/differences between the several versions of windows7.

    Win7 pro and ultimate are made for pro usage, so give "easier" access to those tools.

    Premium versions are aimed at families and "mainstream" usage, generaly, a mainstream user doesn't need local webserver.

    I don't know for sure, but it's an idea I had, maybe it's worth investigating for ASHLEY.

  • Microsoft's documentation implies the server we use is available in every single version of Windows since XP SP2.

  • Hay everyone, sorry for the bump...

    I'm new here and have the exact same problem.

    Even with openned "tutorial" files already in Construct, i simply can't preview the game at all.

    Always giving me this

    can't find localhost:50000 adress etc..

    I tried changing port to 50001 or 50100 or between. Changes nothing.

    I run on the free version of it on steam. (can't download the standalone from scierra.)

    and with latest drivers browsers.

    Anyway, my computer is very clean and stable with any other application.

  • I had the same problem when trying to run Construct 2 on my other computer that has Windows XP SP3 installed on it. I tried everything suggested on the Construct forums and nothing worked. The only fix that I found was to uninstall the newer Construct version and install a slightly older version of Construct 2. The version is r201. You can grab it here:

    Ashley had mentioned in one of his post that there was indeed a change to the preview on version r202, I believe. As far as I know, any version above r201 won't work on Windows Xp SP3 that I have tried(at least on my machine). Correct me if I'm wrong, but it seems to be a bug since Windows XP is becoming so outdated. The newer versions of Construct 2 (r202 and higher) ran excellent on my Windows 7 Professional PC (though I never test on my other PC with Windows Home version)

    So for anybody having this same issue, and if all else fails -- I recommend uninstalling the current Construct 2 version you have (if it is r202 or above) and install version r201 instead (1st Apr, 2015). It is the only work around on this issue I have found for my XP machine.

    It kinda sucks downgrading, but if you don't have a Windows 7 Pro O.S. then you can fall back on this until you get the O.S. or a new PC with Windows 7 Pro (or higher) on it.


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)