Game doesnt load various errors in console

0 favourites
  • 8 posts
From the Asset Store
Human/Character Base Pixel Art Sprites in various poses (nearly 100 files)
  • Problem Description

    Uploaded to google drive loading bar gets stuck. Looked at the Console on chrome and its has various errors about c2runtime and some image files missing even though they are all there???

    Not sure if this has something to do with Spriter plugin. I think Ashley is helping with its development?

    Spriter version 6.1 and latest plugin being used.

    Attach a Capx

    Cant post Capx its the final full game. Is there an email I can send it to Ashley

    Description of Capx

    Fun filled game lol. Its the full game an arcade style platformer

    Steps to Reproduce Bug

    Observed Result

    loading bar gets stuck doesnt loading anything

    Expected Result

    Game starts and works

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)
    • Internet Explorer: (YES)

    Operating System and Service Pack

    windows 8.1

    Construct 2 Version ID

    ____ 163 ____

    Thanks for your help.

  • Closing as not a bug: the server is responding with 404 Not Found for lots of files, which simply means you have not uploaded all the files correctly.

  • All the Files are there it looks like it was an issue with google drive not loading the files but if you check the link now and look at the console it just shows the error c2runtime says "Uncaught TypeError: Cannot read property 'type' of null c2runtime.js:5114"

    I dont know what that means but all the files are there. The game runs fine when im using preview. But now that I export it it wont work. I know im uploading everything correctly to google drive cause I just tested out one of the templates by exporting and uploading to google drive and it works fine. If you can please help with this issue that would be great. I'm ready to start selling this game to publishers but wont be able to unless it actually works on a server. I'm more than happy to send you the capx file but it has to be to you personally I don't want my work floating around when I worked on this game for a while.


  • It might be a problem with Google Drive, in which case it's still not a Construct 2 bug. Lots of people report bugs when they haven't uploaded their files properly.

  • If you've any third-party plugins on your game, I recommend try exporting with Minify box unchecked then upload again to Google Drive.

  • I did that and the same thing happens. Any other suggestions? I tested to see if it was the spriter plugin by uploading the platformer template to google drive. I uploaded 2 different copies. one had no spriter animations and the other has some spriter animations. They both loaded fine. So I have zero clue as to why my game doesnt work I did the same thing that I did to the templates when exporting and when uploading to google drive. as you can see here ( ... index.html) and ( ... index.html) The animations do load, as does the game. But why not my actual finished product? This is pretty frustrating I have spent the last couple of days trying to figure this out and nothing. The game works perfectly fine on my local server and even over wifi to my ipad. So why not on google drive when the other examples work just fine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I found this topic, on the Russian based community forum for Construct 2, It might be useful an help you out with your issue you maybe having. - You'll need to translate it to english using Google Translation.

  • ya those are the instructions on how to upload to google drive they did mention permissions for the folders above the index file file im guessing but they have all been made public so that shouldnt be the issue. plus I got the other examples to work just fine but still my actual game doesnt work. I dont think it has to do with google drive issues.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)