Game Crashes On Load With 3 Errors, No Plugins

  • Link to .capx file (required!):

    I'd prefer not to release publicly because this will be a paid app on the Google Play store, and it is very nearly done. IM me for a Dropbox link. Sorry if this is against the rules ;)

    Steps to reproduce:

    1. Run the game in Chrome

    Observed result:

    I get three errors: The first is this, when I close the first one I get this, then when I close the second one I get this. Then I see a black screen.

    Expected result:

    The game loads properly and plays.

    Browsers affected:

    Chrome: Yes

    Firefox: N/A (Not installed)

    Internet Explorer: N/A (Broken on my computer ;D)

    Operating system & service pack:

    Windows 8

    Construct 2 version:

    r139 64-bit

  • Tried to put a link in by editing the post after checking the rule thread, but it won't actually let me put a link in by editing. Hmm. I just get the 'You need 500 rep' thing.

  • At worst you can try to send your capx to ashley@scirra.com, but you'll need a simplified version, not a "almost finished" project of thousand of events.

    In the meantime you can check for errors in your browser and see if it gives you any clue.

    I must admit the error messages are pretty intriguing, are you REALLY sure you're not using any third-part plugin AT ALL ?

  • Kyatric

    Nope, I'm not using any plugins at all. I'll check and see what my browser spits out.

  • Here is a link after all, I should've put one there in the first place but I can't 'Edit Post' it in: www DOT dropbox DOT com/s/f44f94t45abrnv1/CorridorRun.capx

  • I'm not of much help, but seeing that this post has almost 500 views but no comments impelled me to post something.

    Looking at the JS error, and then going to line 1117 of data.js, that line references sprite19-default-000.png, which doesn't exist anywhere it seems.

    It's particularly suspicious that there are Sprite folders in the animations directory of your unzipped capx numbered through and past Sprite19, but not including Sprite19.

    An error occurs when you try and export the project.

    Seems like your project is corrupt in some way... Have you tried to rebuild the project by making a new one, making all the objects again, and pasting in the events?

  • Please OrangeFlash don't post several topics of the same error.

    Bugs take time to get reviewed/fixed, and it's summer holiday here in Europe.

    Please be patient and keep to only this thread as far as this specific bug is concerned.

  • CannedEssence is on the right track. I could find no reference to Sprite19, so just delete it from the Projects tab, and the game runs!

  • Okay, I'll give that a go. Thanks guys!

  • CannedEssence and blackhornet, you were right! I simply deleted Sprite19 from the Project tab and now the project runs fine. Thank you so much!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as resolved. However it sounds like there was a bug in C2 that caused a sprite image to go missing. We'd like to fix that if possible, so if you can reproduce that and report a bug for it we can investigate further to try ensure it doesn't happen again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)