Freeze when adding New Event or Action

  • I have a confusing problem with Construct 2 freezing when I try to add either a new event or an action. It has been working fine, until today. The same thing happens whether I try to add events/actions to either an existing game or a new one. I am using the latest release of r95.

    The games load and run without any problems, it's just when adding the events or actions. However, I don't seem to have the same problem when working with Construct 2 (and the same games) on another laptop.

    I have checked that I have the latest drivers installed and run a full scan. I have also reinstalled Construct 2.

    My laptop specs are:

    Intel Core i7, 2.20ghz, 8gb RAM, Windows 7 64 bit, AMD Radeon 6750M, mobile Intel HD Graphics

    Any ideas would be greatly appreciated.

    Thanks

  • This is very odd, I've not heard anyone else reporting this before, and obviously adding actions and conditions is a very common thing to do.

    So I would think this might be a problem with your computer somehow... not sure there's anything we can do to fix it if it works on everyone else's computers.

  • I was just hoping someone else may have experienced similar problems and may have an answer for me. It just seems strange that all was going well, then suddenly, not...

    Looks like I may have to stick with using the old laptop, at least Construct 2 works on that one.

    Thanks for your help.

  • Ooops! Found the problem, I don't dare mention what it was, I'll leave it up to others to guess.... <img src="smileys/smiley9.gif" border="0" align="middle" />

  • Mazzran, can you say what the cause of the problem was? This will help other users who find the thread by search. I'm also keen to know if there's anything we could change in Construct 2 to prevent other users running in to this issue.

  • Errr, well it has to do with having used a second monitor, then leaving Construct 2 for a while, coming back and not turning on the second monitor.....

    The appropriate event/action dialog box was appearing on the monitor that was not turned on.....

    I can hear everyone laughing!!!

  • ... I can hear everyone laughing!!!o. no, we're saying, we've been there and done things like that - and weren't so honest about it.

  • Mazzran: I don't know if this is how you resolved your issue, you have a "Reset dialogs" button in the preferences dialog.

    Ashley: maybe adding a shortcut to the "Reset Dialogs" button in the "Quick Access Toolbar" could help ?

  • Hehe, I just resolved my issue by turning on the second monitor...

    Shall check out your hints though. <img src="smileys/smiley4.gif" border="0" align="middle" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • OH, OK, heh! :) I guess there's not much we can do to prevent that... closing this bug report now.

  • yes , even i was facing the same issue caused by the monitor only. It is solved now.

  • I am having this issue however I have both my monitors turned on, although I am not seeing the dialog box. Is there anyway to re-centre this dialogue so that I can get to it?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)