Error Run Project

  • Problem Description

    When i run my project or sample project in Construct 2 R 200 or Newer, i get Server Not Found browser i use Google Chrome and i use another browser again still Server Not Found.

    But if i use Construct 2 R 19x or Later, i can run in my browser.

    Attach a Capx

    None.

    Description of Capx

    None.

    Steps to Reproduce Bug

    • I open my project or sample project.
    • I Run Layout.
    • In browser, i get error Server Not Found.

    Observed Result

    Error Server Not Found, in url bar browser www . localhost . com : 50000 (not localhost:50000, like if i use Construct 2 19x or Later)

    Expected Result

    Can run, for preview in browser.

    Affected Browsers

    • Chrome: Yes
    • FireFox: Yes
    • Internet Explorer: Yes

    Operating System and Service Pack

    Windows XP Service Pack 3.

    Construct 2 Version ID

    Construct 2 R200 or Newer.

    * Sorry for my bad grammar.

  • I agree , I am having the same problem as of r206 .

  • I agree , I am having the same problem as of r206 .

    Hi granpa, so you still use Construct R19x?

  • Have you tried the steps in Troubleshooting C2's preview server?

  • Ashley I tried what was mentioned in troubleshooting with no avail. I've never had this happen before and noticed the browser was adding .com after localhost and would not respond even when correcting it to . I changed firefox config settings to remove the suffix .com to localhost and still no luck . I uninstalled c2 r206 and went back to r200 and everything works fine again . Just some info........

  • I agree , I am having the same problem as of r206 . I use the r199 and does not give me problems with localhost: 50000 /

  • granpa - are you sure you are using the right address? It is definitely http://localhost:50000 - anything else is wrong (no www, no .com, nothing like that)

  • If i use R200 or Newer, address run project auto to www . localhost . com : 50000 .

    Then i manual change address to but server not found.

    Why?

  • This is true for r206 , for some reason r206 makes the browser append a .com to the localhost and r200 leaves the address alone .

  • Ashley I forgot to add that this only happens on xp sp3 , i don't have any problems on win7 ultimate or 8.1 , sorry should have mentioned this as well .

  • granpa - you really should update. Microsoft dropped support for Windows XP, and we recommended XP users upgrade over a year ago. As the post says XP is so old now that if it's difficult to fix XP-specific bugs, then we probably just won't fix them.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Exactly the same problem for me. It is as if the server is not launched.

  • I'm sorry to add myself to the ones who cannot run a browser preview on version r206.

    I tried any browser I installed that are Chrome, Firefox and IE, but the answer is always "Server unavailable" or something similar.

    Also trying both your troubleshooting and tip on this post have not solved the situation

    Going back to Construct 2 r199 everything returned working fine. Me too I'm running C2 on a Xp SP3 machine.

    Maybe something (development environment?) broken backward compatibility with Xp.

    An advice for ArpibZZaszi and other ones: Firefox adds "www." and ".com" only after failing on "localhost:5000". The process is almost invisible, but it is a clue that Firefox was not able to resolve to provided address and it is trying to "autocomplete" it to make it working. It's a feature

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)