Error with Javascript Minification

0 favourites
  • 7 posts
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • Problem Description

    When trying to Export an HTML5 project, if the minify javascript option is checked, export fails with message "Error during export, cannot open file c2Runtime_min.js"

    Both java 32 and 64bit are installed and updated. This is version r173 64bit/steam

    Running both steam and Construct as Administrator

    Fresh install of Windows 8.1 (new machine) AND Verified on fresh install Windows 8.1 (old machine)

    Error happens on any Capx.

    Attach a Capx

    N/A happens on a fresh project and also on old projects

    Description of Capx


    Steps to Reproduce Bug

    • Step 1: Install Construct 2
    • Step 2: Install Java 32 and 64 (I also tried uninstalling and reinstalling, only 32, only 64, etc)
    • Step 3: export and choose HTMl5

    Observed Result

    process opens multiple command windows and then finally fails with error message

    Expected Result

    Minified javascript

    Affected Browsers


    Operating System and Service Pack

    Windows 8.1 fully patched and updated

    Construct 2 Version ID

    r173 64bit/steam

  • Can't reproduce, works here. Are you sure Java is installed correctly on your machine and that you have full read-write permission to the export folder? Does it reproduce on any other computers?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yes, Java is installed correctly and verfied (both 32bit and 64bit versions). I have tried on two separate machines. Java version is 7 update 65. I even tried a brand new empty project and on both machines I get the same error. Both machines I am logged in as admin, also running Steam as an administrator and Construct as well.

    Both machines are fresh installs (one machine is a new machine, the other is my old machine which I reloaded windows on)

    My version of Construct is the steam version, personal license. I have given the "Everyone" group full access to the folder and it is the same issue.

    Could this be a Steam version or windows 8.1 issue maybe?

  • Same error for me if the minify javascript option is checked during any export.

    "Error during export, cannot open file c2Runtime_min.js"

    The error only happen with the construct2 64 bits version, if I use the 32bit version, the minify is working well.

    As Bossmojoman java 32 and 64bit are both installed and updated.

    Operating System and Service Pack


    Windows 8.1

    Construct 2 Version ID



  • Found a random forum about unrelated Java bugs, and decided to see if I have the same version. Upon opening CMD and typing in the command "java -version", it reports back with a similar worded error: "Error: could not open `C:\Program Files\Java\jre6\lib\amd64\jvm.cfg'" Boom. It is a problem with java. Now keep in mind, this is even after having updated Java to the most recent version (version 7 update 67).

    Decided to take another look at the Java files on my drive... noticed something out of place.

    The Solution for me: Delete the JRE folder in WINDOWS; it doesn't belong. C:\WINDOWS\jre

    Very strange, but it works likes a charm. Minify Script now works, as does java -version command in CMD.

    Hope this helps you guys out!

  • Thanks hermitpenguin, had exact same issue, followed your instructions, worked perfectly!

  • You are my new best friends. Thank you!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)