Crash on Startup

  • On Construct 2 startup, when I click "New Project" or even try to open

    example projects the following error is displayed:

    • Construct 2 game creator has stopped working -

    Then Construct 2 application closes.

    Attempts to fix myself:

    • Uninstalled and reinstalled
    • Uninstalled, redownloaded and reinstalled
    • Restarted Computer
    • Ensured computer has updated graphics driver

    Construct 2 Version - 108.2

    Specs

    MS Windows 7 Home Premium 64-bit SP1

    AMD Phenom II X4 955 Processor

    4.0GB RAM

    ATI Radeon HD 5670

  • You could try installing the latest .NET Framework, and Microsoft Visual C++ 2010 Redistributable Package on your PC and see if that helps.

  • This is 100% certainly a graphics card driver bug. There is nothing we can do to fix it. If you definitely have the latest version of your graphics card driver, and it's still broken, all you can do is complain to your graphics card vendor.

  • This is 100% certainly a graphics card driver bug. There is nothing we can do to fix it. If you definitely have the latest version of your graphics card driver, and it's still broken, all you can do is complain to your graphics card vendor.

    Thank you for the link.

    I sent over a service request and demanded a fix.

    I have issues with this video card, not just with Construct 2. Blue Screens, Black Screens, etc. I cannot even trust my computer to work on it, because I am in fear that it will crash, restart by itself, etc.

    LUCKILY, Construct 2 works on my Netbook.

  • I fixed the issue (so far).

    It would be nice to see a reply from you Ashley, to see why these settings would crash Construct 2 on start up and hopefully you could post these findings.

    I went through AMD Engine Control Center and did the following:

    Under 3D Application Settings

    • Unchecked Morphological Filtering
    • Unchecked Tessellation 'AMD Optimized'
    • Unchecked Enable Surface Format Optimization
    • Changed 'Wait for vertical refresh' to 'Off, unless application       specifies
    • Unchecked Triple buffering
    • Everything set to 'Use Application Settings' & set to 'Performance'

    I hope this helps anyone reading this post!

  • hyemynameis - the crash is AMD's fault, there's nothing we can do about it. Their graphics driver crashes. Presumably adjusting some settings runs different code in the driver and avoids the crash.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I understand that it is AMD fault. I am stating that I believe I found the issue and it might help other AMD users, if they have similar issues, to update your posts on AMD issues with Construct 2.

    Thank you for your response by the way.

  • *Not - found the ISSUE*

    Found the solution, I need coffee.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)