Crash - Required resource was unavailable

0 favourites
  • 8 posts
From the Asset Store
Mine those precious space resources & start trading
  • This happens way too often.... if it wasn't for the auto-save, I would have lost hundreds of hours worth of work over the last three weeks. Here is what happens with the screen:

    This happens at least once an hour... sometimes once every hour and a half... and the only way to fix it, is to close Construct, restore my auto-save, and continue working... to which it works great fora bout another 90 minutes, then it does this again. (of course it does it 17 or 18 mins into the auto-save cycle.... to which I changed my cycle to every 15 mins to combat this... and now this happens it seems every 13-14 minutes... ugh(%#)

    Is there anything I can do to resolve this? I have 16GB of ram... and I've tested it for bad memory, to which it passed with flying colors. This seems to have all started with the r160 release... but can't be 100% sure. Any ideas as to what I can do to help you diagnose?

    Ninja edit: I just changed it to every 10 mins now... blah.

  • I now have this set to every 5 minutes.... mainly cause it's frustrating when I forget to save before previewing. This seems to happen every 6th or 7th time I preview my game... I'm 100% sure there is a memory leak with Construct2.

    Is there something I can do to help figure out what it is?

  • Post you system configuration (hardware/OS spec).

    I never encountered such an issue as far as I'm concerned.

    Try to uninstall C2 r163 (as well as all previous versions), re-download and install again.

  • I tried a complete uninstall (even removing registry entries and remaining files) and a re-install.

    Because of the size of my project might have something to do with it, and the inability to go back in versions, I can't test in older versions anymore. All I can say is that it still does it even after all this.

    Brand new Windows 7 64bit install on a Lenovo E531 laptop

    i7 3632QM

    16GB ram pc3 12800

    Like mentioned earlier, this resource not found problem only happens when you go to preview after a number of times. You can actually see Construct2 slowing down shortly before this happens. I have a sneaking suspicion it has something to do with the Tool Tips.... but don't know for sure.

  • Closing, we cannot help with bug reports that do not provide an example .capx or steps to reproduce.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I also experienced this since r164 but only for one project. I'm sorry I cannot post the capx, but as I tried to figure out i found that presumably it's because I copied and used many text instances in a single layout. Almost Every time I previewed my project, I got that error. Then I only copied and used 56 text instances (previously 672). Now I rarely get this error.

    I also used many objects with sine behavior, I dont know if it's contributing to the error or not though.

  • Getting exact same things. The performance seems still be lacking despite last update within C2 Editor. It is not resource hogging. I did multiple diagnostics and C2 should be not able to make my computer so sluggish and finally fail to work every 1-2 hours. It seems there is something really wrong there. I am on Windows 8.1 - Asus 550CA

  • Yeah I'm in the same boat. I get REQUIRED RESOURCE WAS UNAVAILABLE, and then the system locks up.

    Has anyone been able too provide a sample capx of this error to scirra?

    I may provide mine but I will have too add censor blocks to all my sprites (due to NDA) which would take forever.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)