Crash if you open image editor w/ no layouts open

  • If you open the image editor without any layouts opened you'll get an error message. After clicking OK only the animation & frame windows appear but they are blank. If you attempt to close either one C2 will crash.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've tried to do this with 3 different .capx, but it doesn't crash for me. I'm opening a .capx, closing all the layouts, then editing and image and it works fine.

    What are the exact steps you are using? Is it with all .capx or just one particular?

  • I just make sure all layouts are closed, then right-click an object in the hierarchy (project window, not object window) and choose "Edit Animation".

    Error message says:

    ---------------------------

    Construct 2

    ---------------------------

    Please open a layout before editing an object's texture.

    ---------------------------

    OK   

    ---------------------------

    Afterwards half the image editor opens and when I close it C2 crashes.

    It's happened in every .capx in every C2 build for as long as I can remember. Just never got around to reporting it.

  • I just make sure all layouts are closed, then right-click an object in the hierarchy (project window, not object window) and choose "Edit Animation".

    Ah. That's the type of info that can change everything, however.....it still doesn't crash for me.

    Have you tried resetting the dialogs, just in case one has gone walkabout?

  • Well I still get the error when opening it via the object window. Tried resetting the dialogs too, didn't help.

    I think it's clearly a bug else that error message wouldn't pop up..

  • You're probably right, although it is very strange that it doesn't crash for me.

    What version are you using? I'm using r140 beta.

    Hopefully some other kind souls can try this out also before Ashley returns from his hols.

  • I'm interested in this. I currently cannot update any images.    It crashes every time I close the image editor.   v. 139 or r140 beta. uninstalled 2x.

    I'll go try my Laptop.....

  • Closing, please follow the bug report guidelines. Also, I cannot reproduce any problem, it opens the image editor just fine with no layouts open.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)