Construct 2 v269 Closes Randomly

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!

    Ashley Per your request I'm making a new thread about this since the old one is irrelevant at this point and you are right, its pointless to pile onto that thread about v267 since that isn't the current version anyway.

    I'll do my best to describe the problem. I know the Construct team is looking for a concise answer on what is causing this but after reading through the previous thread about v267 I've come to the conclusion that no one really knows what is causing it because the problem cannot be consistently reproduced.

    So here goes, I'm currently using Construct 2 v269, the non-steam version. At random intervals the program crashes. I won't comment on if it happened before v269 because I honestly don't know and I don't want to confuse the issue. I can usually tell it is about to happen because C2 will become unresponsive for about 3 seconds or so and then close with no messages about what happened. Below are the times that I have had this happen to me. I will obviously say that Construct 2 does not close itself out every single time you perform one of these actions, but these do seem to be the operations that trigger the problem.

    1. Auto-save: Personally, I disabled auto-save a while ago because there was about about a 1 in 4 chance that the game would finish auto-saving then stall for a second, then close. It clearly finishing performing the auto-save because I could go to the auto-save file and it would be up to date. This seemed to be the most consistent thing that crashed C2.

    2. Image-Editing: When using the image editor C2 would work fine until you closed the editor. So you could upload or add an image in, do your editing, make more frames etc, all no problem. Once you closed the editor there was a chance, again not consistent, that C2 would just close itself out.

    3. Copy-Paste: Copy-Paste in pretty much any setting (excluding the image editor) seems to cause issues. By any situation I mean copying events or actions, or something like making a duplicate of an object in the project bar. I will say in this case using the copy command (Ctrl+C) never seems to crash C2. It's when you paste something you copied that C2 crashes. Again as usual you will hit (Ctrl+V) the game will stall for a second without pasting anything and then crash. As for duplicating objects you click "duplicate" and then it stalls and closes without making the copy.

    Those three things are the only things I know of that crash C2 on a regular basis, perhaps there are others but I'd rather not muddy the waters any more than they already are. At the moment I am working in C2 about 8 hours a day and I'd say I see anywhere from 2 to 4 crashes a day. I've basically just started quick saving like I'm playing Skyrim to avoid losing work at this point. If people reply to this thread saying other things crash C2 you may put some stock in it. Its possible that other things crash the program but, if you are willing to take me at my word, these are the things I can see really causing an issue. I know you don't want to go on a wild goose chase through the engine, but it is basically making C2 unusable at this point.

    For my own thoughts, if you want to hear them, it seems like something is being bogged down in the engine. The capx I am working with is 7,222kb, suffice to say its got a lot of events and sprites and things. Perhaps this has nothing to do with it but it seems to me that the engine is either hitting an error that doesn't hav a catch somewhere in the code, or there is something about larger projects that it can't handle. That's a shot in the dark obviously. My only other guess is the inconsistency in the problem could suggest something like a memory leak in the code or something that builds up over time, or maybe its something to do with how C2 uses RAM. Based on what I've read and my own experiences C2 never crashes quickly after launching it. It always seems to be something that happens after an hour or two, and once it closes and reopens you get another good amount of time out of it. All three of the triggers described above would likely take a more sizable chunk of memory to perform the actions so maybe its something to do with how it handles memory on a larger scale, sorry I know that's not really much help.

    In any case I've already wrote more than people want to read. I'll probably jump ship to C3 soon, but I figured I should put in my two cents before I do, maybe it will help the people sticking with C2. On a final note, I know these are supposed to have a capx attached. The only capx I have is the game I've been working on for about a year so I'd rather not post it publicly. If you have some way I can send it to you privately I'd be happy to do so, although like I said before it seems that this problem can't be reproduced consistently so I don't know how much it would help you. Not to mention you need to be actively working for a while before the game will crash. In any case thanks for looking into this I know a lot of people want this fixed but I understand asking someone to tear through an engine to look for one problem that can't even be clearly identified is nearly impossible.

    As one last thing, and I'm sure you have people to do this for you anyway but I figure I'll offer. If you have some sort of terminal like program that monitors C2 as it runs and records everything C2 is doing that might show where it is crashing. If you have some sort of development program like that I'd be more than happy to attach it to my C2 and send you the logs. Obviously, that's hypothetical based on if C2 even has that, in my experience a lot of programs have a system for debugging so I thought I'd mention it. Anyway, good luck, and thanks.

    With issues that are so difficult to pin down it would be helpful to have:

    1. Full system details of anyone who is affected by this
    2. Full system details of anyone who is not affected by this - if there are people out there who are working away just fine in r269. This could help start to correlate the issue with certain system configurations. It may for example actually be caused by something like a buggy GPU driver update for certain nVidia GPUs - we've certainly had serious and equally difficult issues in the past along those lines.
    3. Use all of r265, r266, r267, r268 and r269 for long sessions and identify where the stability issue first showed up (if it is newer than r265). This will help narrow down the set of possible changes that could have started causing a problem.
    4. Try working with Preferences -> Misc -> Other -> Icon mode set to "Don't show unique icons". If this is anything like previous leaks involving Windows GDI and the "10000 graphics objects is enough for anyone" limit in Windows, that setting may work around it.

    Hopefully that provides some leads and some ways others can contribute helpfully to figuring out what's going on here.

    Hello Ashley, thanks for the quick reply. I don't know about everyone else but as far as system specs go I can at least give you mine. I don't know how in depth you want so I'll just hit the basics. I have a laptop and desktop both of which crash, specs are below.


    OS: Windows 10 v1803

    HDD: Sandisk SD8SN8U 128GB SSD

    RAM: 8GB

    Processor: Intel Core i5-6200U

    Graphics Card: Intel HD Graphics 520


    OS: Windows v1803

    HDD: Reactor 1TB SSD

    RAM: 16GB

    Processor: Intel Core i5-4760K

    Graphics Card: Nvidia GTX 1080 4GB VRAM

    As a small aside I just checked my drivers and everything is up to date regarding graphics cards at least on both machines.

    I also just changed my preferences to not show unique icons, I didn't even know this was a thing or that the Windows GDI had a hard cap. It's possible at least that this was causing this issue for me I'll try to reply if I see the problem go away. Thanks again for the help.

    Ashley Just an update for you. Switching C2 over to using generic icons hasn't changed anything. C2 crashed once about 2 hours from the copy-paste bug I was talking about before. Just now it crashed again. This time I had minimized a chrome tab, then re-maximized C2 and tried to zoom into a layout via the mouse wheel. It never zoomed in and then just closed.

    I've been thinking for the past few minutes but I can't think of any reason zooming in would cause C2 to close. The only tangentially related thing I can think of is some sort of bug with C2's UI or how it handles rendering layouts. Anyway that's all I got if there is something you'd like me to try I'd be happy to, otherwise I'll keep going and see what happens.

    I've been thinking for the past few minutes but I can't think of any reason zooming in would cause C2 to close.

    Well, zooming will redraw the Layout View, which is rendered with OpenGL. That suggests it might be a GPU driver bug...

    Well, zooming will redraw the Layout View, which is rendered with OpenGL. That suggests it might be a GPU driver bug...

    I disagree with the GPU driver bug part.

    Unless there were hidden changes done to the OpenGL backend that C2 r266+ is using, there is no reason for why these problems didn't occur in r265 and prior versions.

    I'm using a mid-range PC with Windows 7, AMD FX CPU, the most recent NVIDIA drivers and never experienced any of the mentioned crashing/closing problems yet.

    Well, you can't really rule it out - driver bugs can be non-deterministic, and could involve memory corruption that depend on random unrelated details of the app. And nothing else significant other than redrawing an OpenGL view happens when you zoom the layout view.

    Possibly a dumb question but you say the only thing that happens when you zoom in and out is that openGL redraws itself which seems reasonable. Does anything happen when you click on a layout just to get focus on it so you can zoom in and out. I don't know if that's a thing but I believe you have to click in the layout before you can actually zoom in and out of it. Does that initial click trigger anything? I only ask because I clicked and then immediately tried to zoom in so if that first click does anything significant it could have been that triggering the problem and not the zoom.

    Again sorry if that's a dumb thing to mention, I'm a bit out of my depth here.

    I don't think so, it probably also redraws the OpenGL view on a click as well. This isn't really a useful direction to take the conversation though. The things I outlined in my first reply are the key things to make progress on this.

    Agreed, that's fine, I just looked back at that post and from what I'm getting the only thing left to do is jump back to r265 and test. It may be a little hard for me to find time to have an extended session on r265 but I'll see if I can do something with it when I get a chance.

    At this point I'm sort of wondering if its even a widespread issue anymore. Seems like no one else is really replying so maybe its something specific to my computers at this point. That or people are just staying quiet/not on the forums.

    On a separate note you may want to look at this. I was going to look into some application monitoring stuff and found something called "reliability monitor" that apparently is built into Windows. Anyway, maybe this is useless to you but it tracked when C2 crashed the other day, below the report it gave. Might be useless information for you but on the chance it isn't here it is. Also one last note, the only important sounding thing I saw was the "Exception Code" that's listed, I googled it and according to google that code is passed when the program in question accesses memory it doesn't have rights to, so I guess its something related to that.


    Faulting Application Path: C:\Program Files\Construct 2\Construct2.exe

    Problem signature

    Problem Event Name: APPCRASH

    Application Name: Construct2.exe

    Application Version:

    Application Timestamp: 5cc70180

    Fault Module Name: Construct2.exe

    Fault Module Version:

    Fault Module Timestamp: 5cc70180

    Exception Code: c0000005

    Exception Offset: 00000000006cbd1c

    OS Version: 10.0.17134.

    Locale ID: 1033

    Additional Information 1: 379a

    Additional Information 2: 379a7b5ebf6f82bcefd8e8ce707a4819

    Additional Information 3: 9ecf

    Additional Information 4: 9ecf75b42781a6e5b426653fc27c1b7c

    Extra information about the problem

    Bucket ID: 051aab5b4d221a6a2899034bbc76537b (1772451552166302587)

    Sorry, in this case that type of report does not provide anything particularly useful.

    Even the part about the access violation being the cause of the crash?

    - try using Visual Studio Debug - Attach to Process [ctrl-alt-p] and select the running Construct2.exe. If there is a crash, the report should be more comprehensive.

    Colludium Yeah, I have no idea how to do that, I just spent a half hour trying to figure out how to open the debug menu in visual studio but it doesn't seem to exist.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads


    i can confirm these things happening, like the author mentioned.

    i've been good with r265, since 266 shit goes bad, i've noticed mostly the problem when adding animations and loading images into it etc..

    i've noticed that 266 had some double click sprite fixes, that might be the problem.

    also, from 268 upwards i get random crashes from working, could be the problem with UI libs you've updated in 268.

    my pc is a laptop with 980m, 8gb ram, i7 4860hq 4/8 3,6ghz, 1 tb hdd and 0.5tb ssd samsung.

    pure installation of win1903 version win 10, with latest drivers from intel to nvidia & realtek music.

    the problem existed prior to new drivers, so yeah.. no idea what's with that r269

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)