Construct 2 r250 crashed after launch

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Problem Description

    Can't launch Construct 2 r250 with my personal license. When I remove license file from it's folder, C2 launch as free edition. After that I chose my license, restart C2 and it's crashed with error again. After downgrade C2 to r248 - all good with license file and without it. In my second PC with Win7 64bit r250 run wihthout any errors.

    Attach a Capx


    Description of Capx


    Steps to Reproduce Bug

    • Launch Construct 2 with license file
    • Error
    • Launch Construct 2 without license file
    • All good

    Observed Result

    Construct 2 is crashed when license file is chosen

    Expected Result

    Construct 2 launch without errors

    Operating System and Service Pack

    Windows 7 32bit SP1

    Construct 2 Version ID

    r250 stable

  • Exactly happening here too

    Starts when removing License

    otherwise crash

    [quote:3tx0fg1n]Problem Event Name: APPCRASH

    Application Name: Construct2.exe

    Application Version:

    Application Timestamp: 5a2e8687

    Fault Module Name: Construct2.exe

    Fault Module Version:

    Fault Module Timestamp: 5a2e8687

    Exception Code: c0000005

    Exception Offset: 0014d3a3

    OS Version: 6.3.9600.

    Locale ID: 1033

    Additional Information 1: 5861

    Additional Information 2: 5861822e1919d7c014bbb064c64908b2

    Additional Information 3: a952

    Additional Information 4: a95201d75ca1765d531217a3005ebc2d

    Read our privacy statement online:

    If the online privacy statement is not available, please read our privacy statement offline:


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've no idea what this could be, especially if it seems to be working for most people (I haven't seen many reports of this).

    Can you post your full system specs if you are affected? Perhaps there is something we can correlate from that.

  • OS: Windows 7 Professional 32bit SP1

    DirectX 11

    CPU: Intel Core i3-2120 3.3Ghz

    RAM: 4Gb

    GPU: AMD Radeon HD 7700 Series

    PS: C2 falls when the license is checked, if it is selected. Even if any other text file is selected instead of it (in r248 a message is issued that the license is invalid) - falls too.

  • I have the same problem.

    I bet, the problem happenes only in 32bit build on 32bit operating systems.

    I have Windows 7 Home Extended 32 bit.

    Ashley, check the lisence checking system in 32bit build, you do not see many posts about this problem, cause the most part of users uses 64 bit build.

  • We've had sporadic issues with the build in the past, maybe it's happened again. I did a rebuild of r250, here's another setup link: construct2-r250-setup2.exe

    Does that work better for anyone affected?

  • no, still same error

  • And r249 does work for you? Which builds work exactly?

  • All previous builds (~114-248) started without any problems. r249 too (just checked)

  • I tried with virtual fusion


      windows xp 32 bit r249 free version (working) r249 licensed version (working)
      r250 free version (working) r250 licensed version (crashed)
      windows 7 64 bit no problem
  • here also working on 64 bit

    crashing in 32 Bit

  • I'm getting a crash on new file or file load using R250 on Windows 10 Creator 64bit. Any solution please?

  • I have a similar problem, my version r250 is not launching, i had uninstalled it and reinstalled a few times, i had rebooted my computer a few times too, it didn't work, i had to install the r246 again, it worked well for me.

  • I've no idea what this could be, especially if it seems to be working for most people (I haven't seen many reports of this).

    Can you post your full system specs if you are affected? Perhaps there is something we can correlate from that.

    my notebook also can not run r250 but run r244 well.

    win10 32bit

  • I'm getting the same thing in r244. I tried reinstalling, uninstalling/reinstalling and still getting the same error.

    C2 launches fine for me, but whenever I try to launch any projects is when it locks up and crashes. Even trying to create a new project results in the same lockup and crash

    I can't upgrade to r250 at the moment, the team is on a compressed deadline and we'll be shipping soon.

    The only thing I can think of that's different is when I tried using C2 I got the pop up message about a new update. After that it hasn't been working. :/


    I tried launching it with wifi disabled to see if it was a "phone home" error, but still results in the same lock up and crash.

    The following Windows update were installed yesterday. Which is a day between when C2 was working and it not working now: ... tware-remo ... -kb4053580 ... er-12-2017

    And an update to the Intel Graphics driver.

    The timeline does align with the issue. Let me know if you have any other questions!



    You help is very much appreciated! Thanks!!!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)