Construct 2 crashes when opening a layout

0 favourites
  • 5 posts
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Problem Description

    When I attempt to open a layout the program crashes. This first happened on my big project but when I tried to recreate it with a brand new project I found that even in a brand new project, once I add a new layout and try to open it the program crashes. I can open event sheets just fine. Nothing has changed on my computer recently so i don't know why it started doing this all the sudden.

    Steps to Reproduce Bug

    Open Construct 2.

    Add a layout and try to open it.


    Observed Result

    "Construct 2 game creator has stopped working."

    Expected Result

    I figured the layout would open.

    Operating System and Service Pack

    Vista Home Premium 32bit

    Service Pack 1

    Construct 2 Version ID

    r173 32bit

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I don't wish to sound unhelpful, but this is obviously noting to do with C2 or everyone would be reporting this issue.

    Something has changed on you system or in the C2 installation that has made either or both unstable.

    I would try a clean, vanilla install. Uninstall C2, remove remaining directory (save Plugins if needed), reboot and reinstall. Maybe also try latest beta.

  • I guess you have also tried the administrator mode, too...

  • Closing, this is exactly what happens when your graphics driver is buggy and crashes. Check for updates. You might need to upgrade to Windows 7+ to get the latest driver support.

  • Been happening to me too all morning for no apparent reasons.

    1. open last capx version

    2. "close" any layout in the ribbon menu

    3. from project window, right clicking to open it again. CRASH

    But, seem to have found a workaround. Previously, I had installed the 64 bit version of C2 in (c:/program) directory

    1. completely remove everything for a fresh install. Reboot.

    2. tried to install the 32bit version. Reboot. NO SUCCESS, Same behavior.

    But then I did a fresh install of C2 on a USB flash drive. guess what...Now it is working.

    So if it can help anyone, maybe try this yourself.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)