Construct 2 crashes when accessing any menus

0 favourites
  • 7 posts
From the Asset Store
Casino? money? who knows? but the target is the same!
  • (I filled out all the fields for completion's sake, but if you want any actually useful information, you should probably scroll to the very bottom where I posted the error codes)

    Problem Description

    I open Construct 2, then click any of the menu buttons- File, the gear thing, Home, etc. The program immediately crashes. This happens no matter how long I wait, or if I go to another program first, etc.

    Attach a Capx


    Steps to Reproduce Bug

    • Open Construct 2
    • Click any of the menu items

    Observed Result

    "Construct 2 game creator has stopped working

    Windows can check online for a solution to the problem."

    Expected Result

    The ability to access any part of this program.

    Affected Browsers


    Operating System and Service Pack

    Windows 7 , run through Parallels Desktop 10.2.2 on Mac OS X 10.10.5 Yosemite.

    Construct 2 Version ID

    Construct 2 release r221

    Note: Since I couldn't post much helpful information, here's the exact error that happens when Construct 2 crashes:

    Problem signature:
      Problem Event Name:	APPCRASH
      Application Name:	Construct2.exe
      Application Version:
      Application Timestamp:	569cea62
      Fault Module Name:	Construct2.exe
      Fault Module Version:
      Fault Module Timestamp:	569cea62
      Exception Code:	c000041d
      Exception Offset:	00000000004534b0
      OS Version:	6.1.7600.
      Locale ID:	1033
      Additional Information 1:	0975
      Additional Information 2:	0975f10465122d08f7b7f340d1fabc62
      Additional Information 3:	4f4d
      Additional Information 4:	4f4dac15e01e981ba4c6d1c2822d45e8
    Read our privacy statement online:
    If the online privacy statement is not available, please read our privacy statement offline:
  • Has C2 ever worked?

    This is most likely due to graphics drivers or the Mac implementation of Windows 7 - I don't see how this can be construed as a Construct 2 bug, unfortunately.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Has C2 ever worked?

    This is most likely due to graphics drivers or the Mac implementation of Windows 7 - I don't see how this can be construed as a Construct 2 bug, unfortunately.

    C2 worked the last time I tried using it, which was a few months ago (before the 221 update).

    Thing is, my graphics drivers and version of Parallels were exactly the same the last time I successfully used Construct. Which could be the explanation, except for that backdating the Construct 2 version doesn't fix the problem.

  • Sorry, there's nothing particularly useful in that crash report, so there's nothing much we can do about this.

    Often issues can be caused by the VM, particularly around graphics drivers, so I'm afraid all I can recommend is trying to update the VM or maybe the version of Windows inside the VM.

  • Ashley, bump. have same issue on new PC. Win 7 x64, latest graphic drivers, latest Java, .Net 4.5.2. Crashing on clicking "File" in top menu, or "Customize quick access bar". Tabs (Home, View etc) - working. Even right clicking on "properties" menu (on left side) - crashing.

  • - sorry, still nothing we can do without a full report with steps to reproduce, but even so, sounds very much like a graphics driver problem.

  • I recently managed to fix this problem by updating everything in the Windows update. I also reinstalled Parallels Tools, but the wording of your issue implies that you aren't using Parallels? Anyway, try Windows update.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)