Construct 2 Crash after Exit

0 favourites
  • 14 posts
From the Asset Store
Minimalist Crash Balls is a game where the goal is to hit the ball on the portal, with 20 different levels :)
  • The title says it all.

    I'm using Windows 7, Google Chrome with the latest Construct 2.

    The problem appears for every version since Jan 2012(the first time I found C2)

    I thought It was normal since my projects are saved and nothing was missing but lately my browser could not find localhost:50001

    Even though I set the HTTP Port to 50000,it will appear

    Oops! Google Chrome could not find localhost:50001

    First : It started with a crash after every Exit of C2

    Second : It started messing with the HTTP port

    * It was working before the (second:)!

    I tried the method to fix the problem by changing the HTTP Ports, checking Firewalls and stuff but all doesn't work except File Preview.

    The crash report:

    Problem signature:

    Problem Event Name:     APPCRASH

    Application Name:     Construct2.exe

    Application Version:

    Application Timestamp:     4fedc406

    Fault Module Name:     html5.exporter.dll

    Fault Module Version:

    Fault Module Timestamp:     4fedc42f

    Exception Code:     40000015

    Exception Offset:     002b3385

    OS Version:     6.1.7600.

    Locale ID:     17417

    Additional Information 1:     a4a1

    Additional Information 2:     a4a13c217307fe82cadeb83f29a255dc

    Additional Information 3:     3920

    Additional Information 4:     3920ca4dd68330a0e2cac808c2ada1bc

    Read our privacy statement online:

    If the online privacy statement is not available, please read our privacy statement offline:


    It seems that it was the html5.exporter.dll

    Ashley can u help? THX

  • Have you read troubleshooting Construct 2's preview server? My best guess is that C2 crashed for another reason and that left it's preview server running on port 50000, so the next time you opened C2 it could not use it. In this case it's normal for it to switch to port 50001, and it should continue working fine. So I guess you had not set up your firewall properly - you have to allow a whole port range, usually 50000-50100, not just port 50000 by itself. Rebooting your computer should fix it and return it to port 50000 as well.

    I'm not sure about the crashes on exit - we've had a few scattered reports of it, but it's been something I can't reproduce reliably myself. I'll look in to it further and see if I can make some changes.

  • Thx for the reply Ashley! I'll try to fix this and see if all works well :D Hoping I could preview my projects on html and thx again.

    Love C2 <3

  • Ok...I tried everything "Troubleshooting Construct 2's preview server"

    told me too, but non works...All browsers doesn't work, millions of refresh doesn't work, open one C2 doesn't work, Firewall disable still doesn't work, changing mostly all available ports but doesn't work, no other servers running still doesn't work, RUN as administrator but still doesn't work, don't have preview-on-LAN feature, check the HOSTS file all correct but doesn't work, File option, mostly all my browsers doesn't play(sometimes will, sometimes not) :/

  • Alright, well I made a change for the next beta, so when it arrives give it a shot and let me know if it works. (Did you reboot by the way?)

  • Yep. It happens all the time, of course I rebooted my PC. I don't stay online all the time(I meant PC on). btw, what change?

  • When I checked on some browsers that work with File Preview btw using(beta r98),I found another bug.A sprite object that drawn using the image editor (a simple rectangle) make it crash on File Preview(Javascript error) I hit New ,chose first choice(.capx), select File preview, make a sprite using the image editor, then viewed = CRASH Javascript error ,line 0

  • When I checked on some browsers that work with File Preview btw using(beta r98),I found another bug.A sprite object that drawn using the image editor (a simple rectangle) make it crash on File Preview(Javascript error) I hit New ,chose first choice(.capx), select File preview, make a sprite using the image editor, then viewed = CRASH Javascript error ,line 0

    Old projects made with other versions(that include a sprite made with the image editor) still works fine on File Preview. I open the old projects using the beta version.(the project is made by a stable version)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Does this still happen in r99?

    p.s. do you mind changing your avatar? It makes you look like a member of Scirra staff, but you're not.

  • No. Now, even the file preview was removed, I can't even test anything.I tried using other PC's of mine. It works wonderfully but not on this PC. I check for ALL possible software that has to do with a server port and I uninstall most of them. Still I can't find the root of this problem on this PC. Perhaps I should discard this one and use a new PC. Thanks for the fast update. I appreciate it! THX Ashley.

    p.s. sry for the avatar. Thought could use the logo but I changed it to my own logo.

  • Well, File preview really had to be removed - the bug you reported with File mode isn't really a bug, it's a fundamental security limitation in browsers when viewing files on disk that prevents it from working at all. There are several other issues like that which prevent even simple games from working. So it really makes it useless for previewing games - we can't work around it at all. Since it generally works fine on HTTP mode, we've decided to make that the only available option.

    Is the crash on exit fixed in r99 at least? That would be some progress.

    All I can think of now is:

    1. Try going through the troubleshooting article again with r99, and see if anything helps r99 this time.

    2. Try swapping 'localhost' for ''. E.g. try browsing to or

    3. Go through the preview-on-LAN article - even though you can't use it - and follow the steps to set up the firewall. Make sure your firewall allows the port range 50000 to 50100 (not just port 50000 by itself - and make sure you don't typo, some people enter 5000 instead which won't work).

    4. In preferences try some random different ports from 49000 to 65000, e.g. 63123. It might be the default 50000 port is always in use by something else.

    Let me know if you get anything working - we might be able to add new options in C2.

  • I don't think it's the firewall problem. (But I still did what the tutorial tells me on page 2). The exit error, so far no error but my other laptop has it once.(r99) Still confuse why does my PC doesn't work on previewing http. I don't think its the construct 2 problem. There is something going on on my PC...My PC is clean and healthy. It works last time but not anymore so there must be a reason. Maybe I will try re-formatting my PC but now I would like to stay in search for the root before I reformat my PC so that I could help solve it in case others may have this issue. Can you give me some possibility of anything that would relate to this problem? I would like to see Construct 2 improve and shine :D

    P.S. Why can't free users try Preview-On-LAN? Can't you release it for free? Perhaps letting me try if it works? I'm planning to purchase construct 2 (Business edition )after I got an agreement with a company on my new game project. cheers

  • I'm afraid I'm out of ideas, I have suggested absolutely everything I can think of. Maybe it's down to your computer's configuration like I say, but I don't know anything about how your PC is set up so I don't know how I can help any further!

  • Ashley

    Sry for the bump, I found the problem at last! It was the IIS wasn't installed on my PC. Link:

    Maybe you could add it to your Tutorial/ Manual? :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)