Construct 2 [140] Steam

  • Steps to reproduce:

    1. Try to open Construct 2 Personal beta 140 on Steam

    Observed result:

    The Construct 2 don't open

    and the Steam warning is: [Failed to Start the Game (Missing Executable)]

    Operating system & service pack:

    Windows 8 64 Bit

    Construct 2 version:

    140

  • Maybe try to desinstall/reinstall the application too (since apparently it's missing the executable).

    At worst you should check with Steam the reason why this is happening and what is their advice when such application error happens.

  • I have the same issue. It just started today. It must be something with the 140 beta because if you right click go to properties and opt out of beta Construct will open up.

  • Finally the beta update came on steam, but i have the same error, reinstalling doesnt matter.

    Please fix it.

    //Edit: Found out that the Steam Launcher exe is mising (the file in the folder before C2 32bit/C2 64bit. So you missed to compile the file or upload it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • My steam hasn't updated mine to the new beta, how do I stop it as I got lots to do today and don't want these issues.

    I have marked that I don't want beta's.

  • If you marked that you dont want it, you dont get it.

    But i found an Fix,

    1. mark that you dont want it.

    2. Go into the installation folder, there should be 1 file and 2 folders, rename the file Construct2.exe to Construct231.exe

    3. Now mark that you want the beta update. (In Steam)

    4. Let steam update it.

    5. When the download is finished, rename the Construct231.exe to Construct2.exe

    6. Launch the new r140 beta through Steam!

  • SgtCoti, your temp fix worked and you are right they forgot the .exe file inside the Construct 2 folder.

    I believe this will not cause any further issue, since this file is probably just for the Steam version.

  • SgtConti

    Thanks!!! It really worked. Finally!

  • Awesome thanks for the fix, was panicking a bit there.

  • SgtConti's fix didn't worked for me. In r139 or r140 i got the same error.

    Edit: I renamed the Construct.exe's inside the 32bit and 64 bit construct folders. It didn't worked. There is another Construct.exe outside of this folders. After renaming that, it works.

  • same error.. had to opt out of beta in steam and redownload 139

  • tried to get latest beta, but can't get it too run, had to uninstall and re-install R139.

    C2 is a great idea, but in reality, as software it isn't stable AT ALL, R139 crashes, freezes all the time. It also should never have been put on steam. Steam just can't handle software or C2 just can't handle steam, either way it just doesn't work as software should.

  • They just miss a file, that's all. And you can use the old file of the version 139 (Program Files > Steam > SteamApps > Common > Construct 2 > [Construct2.exe]) if you copy this file elsewhere, update to 140 and paste the old file to the same place it will work.

  • Oops, we stuffed up the r140 Steam update. I just pushed an update now - hopefully that fixes it.

  • Woot! Thank you Ashley, managed to update and it seems to work fine. Got the latest 141 beta.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)