Chrome/Opera User Media not requesting

  • Problem Description

    Problem with User Media.

    When testing and previewing in latest (47.0.2526.73 m) Chrome and in Opera 34.0, I get this error. It works fine in Firefox.

    It worked fine in 4.6 version of chrome.

    Chrome/Opera does not request camera (when exported and hosted).

    Attach a Capx

    https://dl.dropboxusercontent.com/u/965 ... hrome.capx

    Description of Capx

    Requests camera in start.

    Steps to Reproduce Bug

    • Request camera
    • Preview in chrome (47.0.2526.73 m)/Opera 34.0

    Observed Result

    Camera not requested.

    Bug info shown.

    Expected Result

    Camera requested.

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (NO)
    • Operar: (YES)

    Operating System and Service Pack

    Windows 10

    Construct 2 Version ID

    Release 216 (64 bit)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Just tested it, the same bug also happens on Windows 8, and on another copy of windows 10.

    all of them are 47.0.2526.73 m chrome. 46 line of Chrome works fine.

    You can test it here:

    https://vikugurgie.usermd.net/qrcodebad/

    and here:

    http://gurgie.eu/qrcodebad/

    No extra plugins (third party/first party) and objects here, just a single on start of layout event requesting camera at source 0.

    Works fine on firefox and opera. It also happens while testing a bundled webcam example.

    E: the same problem is with the mic user media. I made test on built-in examples too.

    E2: It also does not work when using the latest (218) beta release.

  • Just a quick update - latest Opera stopped working with User media as well.

    It must have something to do with all chromium based browsers.

    E:I found a fix

    you have to use old version of user media + https. Just downloaded very old version of c2 (I tested 108), I am not sure which one will be the last one to work.

    E2: - it allows webcam to work, but crashes when the camera is no longer needed (changing layout etc.)

  • I have the same issue!

    Isn't there a way to make usermedia work on Chrome?

  • This is due to a half-way spec change in Chrome 47. It's already fixed in Canary which means a future version of Chrome will work again, but I added a workaround for the next build as well.

  • I am facing the same issue with latest 216 build.

  • mchulet

    Please don't post in closed bug reports.

    Ashley has already stated that he has added a work-around for the latest build, which is r219.

    Please re-try with the latest build and if it still doesn't work, post a new bug report following all of the reporting requirements.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)