check failure - r120.2

  • Sorry i'm not using the bug template, but I don't think it applies here.

    Got this a moment ago:

    Check failure!

    Expression exception during export.

    Condition: false

    File: Projects\Parameters.cpp

    Line: 809

    Function class era::IExpression *__cdecl

    EventParameterERACallback::GetExpression(void) const

    Build: release 120.2 (64-bit) checked

    Componen: Construct 2 IDE

    (Last Win32 error: 0)

    (it would be great if in future versions, these errors could be easily selected for copy and paste, cos writing them from screen to forums is a pain :)

    I used a loader layout in one of my projects, I went to project properties and changet it to not use the loader layout and deleted the layout that was used as a loader layout, previously changing the "first layout" to some other.

    In the loader layout I could have had (sorry if its not proper english - not my alma mater :) a constant global value, so it may be related to it.

  • I'm getting this same error oddly enough. I haven't tried re-installing yet. I was just coming to see if there was a solution already :C.

    <img src="http://i.imgur.com/wltoghI.png" border="0" />

  • it Ctrl+C to copy this messagebox

    And so after all you need to do is press ctrl+V to paste it in the forum...

    In any case provide a capx and precise steps to reproduce the error, the bug template ALWAYS apply.

    Index: the error is not the same that Ranma reported.

    Please fill a proper bug report with detailed steps and capx.

    Closed until filled with all the missing informations.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • that's fine with me, everything you need to recreate the bug is in the original post, I just wanted to be helpful (for once ;) but if you think this bug is closed - no problem for me to be honest.

    also the "hit ctrl+c" doesnt work for me for some reason, that is why I suggested to make it a textarea of some kind. you want a capx with that? ;)

    now in all serioussness, don't get me wrong, but it's not me that should be pursuing a non bugged ide, it's scirra. closing a bug report just because it doesnt fit into general bug report template is not equal to fixing it.

    cheers anyhow.

  • It really is impossible for us to investigate issues without a .capx and full steps to reproduce. This issue is very likely to be related to the particular project you used so it is absolutely necessary to always provide it.

    Index - that appears to be a different issue, but it looks like something to do with third party plugins. Post a new thread with a complete bug report if you can reproduce it without using any third party plugins.

    tl;dr - if you don't use the bug report template there is a 90% chance your issue will be closed without even being looked at.

  • It really is impossible for us to investigate issues without a .capx and full steps to reproduce. This issue is very likely to be related to the particular project you used so it is absolutely necessary to always provide it.

    it's not, that's what I'm telling you from the start, you can use blank new project, add loader layout, add a constant variable to it, use some action with the constant in second layout and remove the loader layout. bang - crash + project corrupted :)

  • I must have missed the submit button when I made a post (in this thread) about the issue. Anyway, ya- I think it's an old bug from when I broke a plugin and never wanted to search for which one it was. (AKA, I just have a folder filled with old plugins)

    Thanks for the help though. The guy above me posted how to reproduce his issue.

    Cheers.

    EDIT: Posted in a thread that was closed and there's no way to delete my post. >.<

  • posting the exact steps to reproduce from blank new project:

    1) add second layout with event sheet

    2) in the event sheet 2 add a new global constant variable - VARIABLE1

    3) in the event sheet 1 add a new event with condition compare two values, one of them is your "VARIABLE1" constant

    4) delete the event sheet 2.

    5) run game, save, etc - you get error - probably caused by referencing a removed constant.

    hope that helps.

  • Thanks, from that list of steps I could repro and it should be fixed for next build. Please always include steps like that right away, it makes it far easier to resolve issues.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)