All capx are corrupt

  • Problem Description

    From one day to the next, all (60) capx files on my PC are corrupted, It's amazing.

    No more files with this capx extension opens, changing the extension .capx in .zip does no good result. Nor with (7-zip, Winrar, or izarc)

    Even with older version of construct 2. I do not expect anything, but I no longer would use this extension .capx.

    Steps to Reproduce Bug

    • Open a file is impossible
    • Step 2
    • Step 3 etc.

    Observed Result

    Failed to load capx, unable to open its own files.

    Expected Result

    Nothing

    Affected Software

    Construct 2, this software will not open its files

    Operating System and Service Pack

    Windows 8.1

    Construct 2 Version ID

    Version ID of Construct 2, 196-2 64 bits

  • Share an example ' corrupt ' file so we can see if it's your files or your pc?

  • Where are you saving these files? Dropbox, Google/MSoft drive, locally or some other location?

    Hardly likely that a normal program like C2 can both corrupt files and alter file associations. When was the last time you did a full AV and Malware scan?

    Have you tried a clean re-install of C2?

  • Locally 3 HDD and Dropbox and Box...

    I use Bitdefender and I scan (deep scan) my PC yesterday.

    On my other PC the capx are good.

    Thank for all...

    Best regards

  • The file you've attached has no visible header structure. It looks like it has either been encrypted by another program or had it's header information deleted somehow.

  • I saw, I don't know that it happened, It's a pity (3900 files) in this PC...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If Bitdefender mistakenly identified your C2 files as harmful, and is set to fix infected files, this could be the issue. You can try to see if Bitdefender has some vault for backups and try to restore. This is just me guessing as I have never used Bitdefender.

  • Closing as there is no evidence Construct 2 caused this problem. It sounds like hardware failure or a virus or some other fault. This is why you should keep off-site backups.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)