Can't open in multi-user install

0 favourites
  • 4 posts
From the Asset Store
A complete set of Graphic, User Interface element to build 2D mobile game or PC game.
  • Problem Description

    When running Construct 2 in a multi-user environment, I can't even get to the splash screen before the program fails with a generic "Construct 2 game creator has stopped working" and "A problem caused the program to stop working correctly. Please close the program."

    If I click on an existing Capx as any Windows user, however, and have it launch Construct 2, everything works just fine. However, users - the one's that did not originally install the program - are unable to click on a shortcut to the program without getting the aforementioned message.

    What is the correct way to install Construct 2 in a multi-user environment? What privileges are necessary by the users that did not install the program. Could this be a problem with permissions on the c2license.txt or similar files used during the startup of the program?

    In my case, the program is installed as the Windows Administrator and then students use their logins to run the program.

    Attach a Capx


    Description of Capx


    Steps to Reproduce Bug

    • Install Construct 2 as Administrator
    • Send Shortcut to Desktop
    • Login as another use and try to run the program directly

    Observed Result

    "Construct 2 game creator has stopped working" and "A problem caused the program to stop working correctly. Please close the program."

    Expected Result

    Blank project window to appear

    Affected Browsers

    • Chrome: N/A
    • FireFox: N/A
    • Internet Explorer: N/A

    Operating System and Service Pack

    Windows 7 SP1

    Construct 2 Version ID


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi, have you tried to use the latest stable version r178 ?

    Does it still display the same issue ?

    The startup page in C2 is linked to Internet Explorer. Are you sure that your users have the rights to use that browser and that it is up to date ?

    Because before getting to a blank project you're likely to first hit that startup page.

    You may, as an administrator, execute C2 and modify the fact that the startup page needs to be displayed in the preferences dialog, unticking "Show startup page on start".

    Hopefully the preference would apply to other users as well.

    I hope these leads help resolving your issue.

  • Thanks for the reply Kyatric!

    I have not yet tried the latest release r178, but that is definitely on the list of things to try.

    I did think to try setting off the "Show startup on start" option in Preferences and that did not work.

    I figured that startup would use things like startup.html, its dependent images, and the c2license.txt file, etc.

    As of now, local Windows users with the 'Administrators' role can use the program without fail. Users whose Administrator roles comes from Active Directory may not. All admins, however, can use the program if they click on an existing .capx. I have attached the error from the Windows access log to this post; looks like a basic 0xc0000005 access violation.

    Do you know of any other logging the application does or whether debugging the Construct2 executable is even possible? Do you know the mechanics of what happens at startup? There appears to be a window which is quickly minimized before the splash...could that be to blame?



  • Closing, followed this up by email.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)