I cannot open the game I'm working on because of "Check Failure! an animation frame missing".

  • The Problem

    So when I first try to open the game, it gives this error message:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    cannot find animation frame either in last_path or project location

    Condition: FileExists(GetProjectPath().c_str())

    File: Projects\AnimationFrame.cpp

    Line: 239

    Function: class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > __cdecl AnimationFrame::GetActivePath(void) const

    Build: release 260 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 3)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

    The Details

    I have had this software for 2 years, and update it to the beta regularly. I've never seen anything like this. I would consider myself a pro at using the software and none of my events seem weird. Whats so weird about this is when I open layout 1, it is only a white screen. When I press CTRL+A it shows the purple highlight as usual, but no objects are there. When I try to run the game, it gives me an error message and then closes. The other layouts, 2, 3, and 4 seem fine but don't run either. All of my events are there, and fine but I just can't run the game. Even all of my auto-saves and backups give the same result. Even the backup from yesterday won't run. I have no 3rd party plugins imported. Please help! CAPX below.

    The CAPX

    dropbox.com/s/49jfnpy29i1otzt/3564789.capx

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • A whole folder has been deleted from your Animations folder called 'overlay'.

    Simple way around this is to unpack .capx to a new folder using 7-zip or something similar. This will extract the project structure.

    Go into the Animations folder and copy and paste any folder. Rename copied folder to 'overlay'.

    Dbl-click on 'New project.caproj' to launch. It should now load and allow you to fix whatever went wrong.

  • It worked, thank you so much!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)