Cannot export any project

  • Error during exports

    Everytime I want to export my project, some bug screen appears and there is nothing I can do to finish it. AllI can click on is - Ignore, Repeat or Cancel, none of these buttons will eventually export my project. Doesnt matter to which device I want to export the project - Android or iOS or Web ... I tried R170 and R168 -> doesnt work

    No capx necessary

    I cannot upload any capx because that "export error" appears even in an absolutely empty project..

    Bug screens

    1st bug screen

    http://postimg.org/image/hgn2h3toz/

    2st bug screen (when I click Repeat)

    http://postimg.org/image/v0usfuh0p/

    Steps to Reproduce Bug

    File

    Export project

    HTML5 Website, Android, CocoonJS - doesnt matter

    Bug Screens

    Expected Result

    Exported project..

    Affected Browsers

    FireFox: (YES)

    Operating System and Service Pack

    Win 7 Home Premium 64

    Construct 2 Version ID

    R170

  • It seems to affect the minifier (like a file cannot be created it seems), were you able to export before?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This is unlikely to be a bug in C2 as there would have been lots and lots of people posting about it. I for one have no issues exporting from r170, which doesn't mean it isn't C2 at fault for you, just unlikely.

    When did this start occurring? Was it after an OS or GPU update?

    What doe Windows Event Viewer say (if anything)?

    Have you got Java installed (for minify)? What version?

    Have you tried exporting without minify or PNG recompression?

  • well i was exporting without any problem in previous versions - r150-r160 then I stopped and when I decied to start using C2 again, I updated to 170 and suddenly errors appeared...

    I also tried to install the newest version of C2 to another PC and there were export problems again...

    I got Java installed but dont know what minify is ... HOWEVER - it works without minify..

  • OK so the problem is in the minifying script...but I dont know how to make it work, Java is installed but everytime I tried to export with minifying on I got those errors (see above)

  • If you look at this closed bug report - https://www.scirra.com/forum/r169-error-when-export-with-span-class-posthilit-minify-span-option_p783406?#p783406 - then it appears this should have been fixed in r170.

  • Without a .capx and steps to reproduce I feel this is likely caused by either a syntax error in a third party plugin, which causes an error in the minifier, or just the wrong Java version is installed. (You need the 64-bit version if you have the 64-bit version of Construct 2, and the website often guides you to the 32-bit version.) Closing, please make a separate report following all the guidelines (.capx and steps to reproduce + your java version) if you still have a problem.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)