Can't add sprite due to .xml error

0 favourites
  • 4 posts
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • Link to .capx file (required!):

    Steps to reproduce:

    1. Add a sprite (I added just a simple square.)

    2. Save and restart Construct

    3. Load save.

    Observed result:

    When I do the steps above I get this error message. I then have to go to the .xml file and delete the sprite that I created.

    Expected result:

    I expected it to open the project I was working on but I can't add anything.

    Browsers affected:

    Chrome: yes/no

    Firefox: yes/no

    Internet Explorer: yes/no

    Operating system & service pack:

    Windows 7 Home premium Service Pack 1

    Construct 2 version:

    Version 132

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Can't reproduce, works fine for me in r134. Does the beta work for you? Precisely what are you doing, in exact detail, in step 1?

  • In step 1 I am double clicking the layout screen and adding a sprite. Just a box that I fill in with any random color. For the tests that I have conducted I have done blue, orange, and pink. I then close the editor window and the sprite that I created is added to the layout. Then from there I can change it's size. I can give it everything a normal sprite can get all the way to the event sheet. For sake of time and energy I haven't been giving it code because if it is having problems with just existing on the layout I don't want to have to go into the.xml for event sheets and find and delete the instance from there as well. From there if I save then close the program and try to open and load the previous save file it gives me the error that I linked above. I have just tried with the 134 version beta and it still hasn't worked.

    Thank you for the quick response and I hope to hear back soon.

  • I got it working somehow. The file I had saved I renamed a long time ago and recently it didn't like that I renamed it so it was just saving as "New Project" and that one is working just fine.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)