Builds are Failing! Why is This Happening? How Do FIX It? Discontinue support for Android 4.0 (ICS)

  • MY PHONEGAP BUILD:

    Build Date: 2018-10-25 22:28:39 +0000

    --------------------------------------------------------------------------------

    PLUGIN OUTPUT

    --------------------------------------------------------------------------------

    Fetching plugin "https://github.com/MBuchalik/cordova-build-architecture.git" via git clone

    Using shallow clone

    Repository "https://github.com/MBuchalik/cordova-build-architecture.git" checked out to git ref "v1.0.1" at "b787544".

    Installing "cordova-build-architecture" at "1.0.1" for android

    Subproject Path: CordovaLib

    Fetching plugin "cordova-custom-config" via npm

    Installing "cordova-custom-config" at "5.0.2" for android

    Fetching plugin "cordova-plugin-ad-admob" via npm

    Installing "cordova-plugin-ad-admob" at "1.0.118" for android

    Fetching plugin "https://github.com/cranberrygame/cordova-plugin-ad-admob-sdk" via git clone

    Using shallow clone

    Repository "https://github.com/cranberrygame/cordova-plugin-ad-admob-sdk" checked out to git ref "master" at "b22949d".

    Installing "cordova-plugin-ad-admob-sdk" at "1.0.36" for android

    Fetching plugin "https://github.com/cranberrygame/cordova-plugin-extras-google-play-services" via git clone

    Using shallow clone

    Repository "https://github.com/cranberrygame/cordova-plugin-extras-google-play-services" checked out to git ref "master" at "f6f6b28".

    Installing "cordova-plugin-extras-google-play-services" at "1.0.5" for android

    Subproject Path: CordovaLib

    Fetching plugin "cordova-plugin-crosswalk-webview" via npm

    Installing "cordova-plugin-crosswalk-webview" at "2.4.0" for android

    Subproject Path: CordovaLib

    After much discussion and analysis of the market, we have decided to discontinue support for Android 4.0 (ICS) in Crosswalk starting with version 20.

    So the minSdkVersion of Cordova project is configured to 16 by default.

    Fetching plugin "cordova-plugin-file" via npm

    Installing "cordova-plugin-file" at "6.0.1" for android

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Skipping 'cordova-plugin-file' for android

    Fetching plugin "cordova-plugin-inappbrowser" via npm

    Installing "cordova-plugin-inappbrowser" at "3.0.0" for android

    Fetching plugin "cordova-plugin-media" via npm

    Installing "cordova-plugin-media" at "5.0.2" for android

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Skipping 'cordova-plugin-media' for android

    Fetching plugin "cordova-plugin-statusbar" via npm

    Installing "cordova-plugin-statusbar" at "2.4.2" for android

    Fetching plugin "cordova-plugin-whitelist" via npm

    Installing "cordova-plugin-whitelist" at "1.3.3" for android

    This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.

    Fetching plugin "cordova-plugin-wkwebview-engine" via npm

    Installing "cordova-plugin-wkwebview-engine" at "1.1.4" for android

    WARNING: Overriding compileSdkVersion from android-25 (default) to android-26

    WARNING: This is unsupported, please consider updating your phonegap version instead

    --------------------------------------------------------------------------------

    PROJECT PROPERTIES

    --------------------------------------------------------------------------------

    # This file is automatically generated by Android Tools.

    # Do not modify this file -- YOUR CHANGES WILL BE ERASED!

    #

    # This file must be checked in Version Control Systems.

    #

    # To customize properties used by the Ant build system edit

    # "ant.properties", and override values to adapt the script to your

    # project structure.

    #

    # To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home):

    #proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt

    # Project target.

    target=android-26

    android.library.reference.1=CordovaLib

    cordova.gradle.include.1=cordova-build-architecture/magicmotherboard-architecture.gradle

    cordova.system.library.1=com.google.android.gms:play-services-games:+

    cordova.system.library.2=com.google.android.gms:play-services-plus:+

    cordova.system.library.3=com.google.android.gms:play-services-ads:+

    cordova.gradle.include.2=cordova-plugin-crosswalk-webview/magicmotherboard-xwalk.gradle

    --------------------------------------------------------------------------------

    COMPILE OUTPUT

    --------------------------------------------------------------------------------

    Subproject Path: CordovaLib

    null

    The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.

    at build_7kjgdbl9dafpgfgqjl82cicth.run(/project/build.gradle:158)

    org.xwalk:xwalk_core_library:23+

    The JavaCompile.setDependencyCacheDir() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    Incremental java compilation is an incubating feature.

    The TaskInputs.source(Object) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use TaskInputs.file(Object).skipWhenEmpty() instead.

    The ProjectDependency.getProjectConfiguration() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    ModuleDependency.getConfiguration() has been deprecated and is scheduled to be removed in Gradle 4.0. Use ModuleDependency.getTargetConfiguration() instead.

    Download maven.google.com/com/google/android/gms/play-services-games/16.0.0/play-services-games-16.0.0.pom

    Download maven.google.com/com/google/android/gms/play-services-plus/16.0.0/play-services-plus-16.0.0.pom

    Download maven.google.com/com/google/android/gms/play-services-drive/16.0.0/play-services-drive-16.0.0.pom

    Download maven.google.com/com/google/android/gms/play-services-audience/16.0.0/play-services-audience-16.0.0.pom

    Download maven.google.com/com/google/android/gms/play-services-drive/16.0.0/play-services-drive-16.0.0.aar

    Download maven.google.com/com/google/android/gms/play-services-games/16.0.0/play-services-games-16.0.0.aar

    Download maven.google.com/com/google/android/gms/play-services-audience/16.0.0/play-services-audience-16.0.0.aar

    Download maven.google.com/com/google/android/gms/play-services-plus/16.0.0/play-services-plus-16.0.0.aar

    :preBuild UP-TO-DATE

    :preArmv7ReleaseBuild UP-TO-DATE

    :checkArmv7ReleaseManifest

    :preArmv7DebugBuild UP-TO-DATE

    :preX86DebugBuild UP-TO-DATE

    :preX86ReleaseBuild UP-TO-DATE

    :CordovaLib:preBuild UP-TO-DATE

    :CordovaLib:preDebugBuild UP-TO-DATE

    :CordovaLib:checkDebugManifest

    :CordovaLib:prepareDebugDependencies

    :CordovaLib:compileDebugAidl

    :CordovaLib:compileDebugNdk UP-TO-DATE

    :CordovaLib:compileLint

    :CordovaLib:copyDebugLint UP-TO-DATE

    :CordovaLib:mergeDebugShaders

    :CordovaLib:compileDebugShaders

    :CordovaLib:generateDebugAssets

    :CordovaLib:mergeDebugAssets

    :CordovaLib:mergeDebugProguardFiles

    :CordovaLib:packageDebugRenderscript UP-TO-DATE

    :CordovaLib:compileDebugRenderscript

    :CordovaLib:generateDebugResValues

    :CordovaLib:generateDebugResources

    :CordovaLib:packageDebugResources

    :CordovaLib:processDebugManifest

    :CordovaLib:generateDebugBuildConfig

    :CordovaLib:processDebugResources

    :CordovaLib:generateDebugSources

    :CordovaLib:incrementalDebugJavaCompilationSafeguard

    :CordovaLib:compileDebugJavaWithJavac

    :CordovaLib:compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    :CordovaLib:processDebugJavaRes UP-TO-DATE

    :CordovaLib:transformResourcesWithMergeJavaResForDebug

    :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug

    :CordovaLib:mergeDebugJniLibFolders

    :CordovaLib:transformNative_libsWithMergeJniLibsForDebug

    :CordovaLib:transformNative_libsWithSyncJniLibsForDebug

    :CordovaLib:bundleDebug

    :CordovaLib:preReleaseBuild UP-TO-DATE

    :CordovaLib:checkReleaseManifest

    :CordovaLib:prepareReleaseDependencies

    :CordovaLib:compileReleaseAidl

    :CordovaLib:compileReleaseNdk UP-TO-DATE

    :CordovaLib:copyReleaseLint UP-TO-DATE

    :CordovaLib:mergeReleaseShaders

    :CordovaLib:compileReleaseShaders

    :CordovaLib:generateReleaseAssets

    :CordovaLib:mergeReleaseAssets

    :CordovaLib:mergeReleaseProguardFiles

    :CordovaLib:packageReleaseRenderscript UP-TO-DATE

    :CordovaLib:compileReleaseRenderscript

    :CordovaLib:generateReleaseResValues

    :CordovaLib:generateReleaseResources

    :CordovaLib:packageReleaseResources

    :CordovaLib:processReleaseManifest

    :CordovaLib:generateReleaseBuildConfig

    :CordovaLib:processReleaseResources

    :CordovaLib:generateReleaseSources

    :CordovaLib:incrementalReleaseJavaCompilationSafeguard

    :CordovaLib:compileReleaseJavaWithJavac

    :CordovaLib:compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    :CordovaLib:processReleaseJavaRes UP-TO-DATE

    :CordovaLib:transformResourcesWithMergeJavaResForRelease

    :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForRelease

    :CordovaLib:mergeReleaseJniLibFolders

    :CordovaLib:transformNative_libsWithMergeJniLibsForRelease

    :CordovaLib:transformNative_libsWithSyncJniLibsForRelease

    :CordovaLib:bundleRelease

    :prepareAndroidArchCoreRuntime111Library

    :prepareAndroidArchLifecycleLivedata111Library

    :prepareAndroidArchLifecycleLivedataCore111Library

    :prepareAndroidArchLifecycleRuntime111Library

    :prepareAndroidArchLifecycleViewmodel111Library

    :prepareComAndroidSupportAsynclayoutinflater2800Library

    :prepareComAndroidSupportCoordinatorlayout2800Library

    :prepareComAndroidSupportCursoradapter2800Library

    :prepareComAndroidSupportCustomtabs2610Library

    :prepareComAndroidSupportCustomview2800Library

    :prepareComAndroidSupportDocumentfile2800Library

    :prepareComAndroidSupportDrawerlayout2800Library

    :prepareComAndroidSupportInterpolator2800Library

    :prepareComAndroidSupportLoader2800Library

    :prepareComAndroidSupportLocalbroadcastmanager2800Library

    :prepareComAndroidSupportPrint2800Library

    :prepareComAndroidSupportSlidingpanelayout2800Library

    :prepareComAndroidSupportSupportCompat2800Library

    :prepareComAndroidSupportSupportCoreUi2800Library

    :prepareComAndroidSupportSupportCoreUtils2800Library

    :prepareComAndroidSupportSupportFragment2800Library

    :prepareComAndroidSupportSupportMediaCompat2800Library

    :prepareComAndroidSupportSupportV42800Library

    :prepareComAndroidSupportSwiperefreshlayout2800Library

    :prepareComAndroidSupportVersionedparcelable2800Library

    :prepareComAndroidSupportViewpager2800Library

    :prepareComGoogleAndroidGmsPlayServicesAds1700Library

    :prepareComGoogleAndroidGmsPlayServicesAdsBase1700Library

    :prepareComGoogleAndroidGmsPlayServicesAdsIdentifier1600Library

    :prepareComGoogleAndroidGmsPlayServicesAdsLite1700Library

    :prepareComGoogleAndroidGmsPlayServicesAudience1600Library

    :prepareComGoogleAndroidGmsPlayServicesBase1601Library

    :prepareComGoogleAndroidGmsPlayServicesBasement1601Library

    :prepareComGoogleAndroidGmsPlayServicesDrive1600Library

    :prepareComGoogleAndroidGmsPlayServicesGames1600Library

    :prepareComGoogleAndroidGmsPlayServicesGass1700Library

    :prepareComGoogleAndroidGmsPlayServicesMeasurementBase1603Library

    :prepareComGoogleAndroidGmsPlayServicesMeasurementSdkApi1602Library

    :prepareComGoogleAndroidGmsPlayServicesPlus1600Library

    :prepareComGoogleAndroidGmsPlayServicesTasks1601Library

    :prepareOrgXwalkXwalk_core_library23535894Library

    :prepareProjectCordovaLibUnspecifiedReleaseLibrary

    :prepareArmv7ReleaseDependencies

    :compileArmv7ReleaseAidl

    :compileArmv7ReleaseRenderscript

    :generateArmv7ReleaseBuildConfig

    :mergeArmv7ReleaseShaders

    :compileArmv7ReleaseShaders

    :generateArmv7ReleaseAssets

    :mergeArmv7ReleaseAssets

    :createXwalkCommandLineFileArmv7Release

    :generateArmv7ReleaseResValues

    :generateArmv7ReleaseResources

    :mergeArmv7ReleaseResources

    :processArmv7ReleaseManifest

    :processArmv7ReleaseResources/project/build/intermediates/manifests/full/armv7/release/AndroidManifest.xml:27: AAPT: No resource identifier found for attribute 'appComponentFactory' in package 'android'

    /project/build/intermediates/manifests/full/armv7/release/AndroidManifest.xml:27: error: No resource identifier found for attribute 'appComponentFactory' in package 'android'

    FAILED

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':processArmv7ReleaseResources'.

    com.android.ide.common.process.ProcessException: Failed to execute aapt

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 13.13 secs

    Error: /project/gradlew: Command failed with exit code 1 Error output:

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    /project/build/intermediates/manifests/full/armv7/release/AndroidManifest.xml:27: AAPT: No resource identifier found for attribute 'appComponentFactory' in package 'android'

    /project/build/intermediates/manifests/full/armv7/release/AndroidManifest.xml:27: error: No resource identifier found for attribute 'appComponentFactory' in package 'android'

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':processArmv7ReleaseResources'.

    com.android.ide.common.process.ProcessException: Failed to execute aapt

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)

    at emitTwo (events.js:106:13)

    at ChildProcess.emit (events.js:191:7)

    at maybeClose (internal/child_process.js:877:16)

    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • We now only support Android 5.0+. See the release notes here

    Android 5.0+ covers ~90% of devices. According to Google's own stats, only 0.3% of devices still use 4.0 (ICS).

  • Thanks, Ashley... I changed it today, to 5.0+ [Lollipop-Webview], but I'm still having issues. What do I need to do? I'm confused... I'm I supposed to change something in the config.xml?

    This was my setup...

    dropbox.com/s/fz5b117zsbscbzk/eferter.JPG

    dropbox.com/s/xg5t85ar1cmlhhj/1111.JPG

    This is what the Phonegap Log is saying now...

    Build Date: 2018-10-26 22:28:12 +0000

    --------------------------------------------------------------------------------

    PLUGIN OUTPUT

    --------------------------------------------------------------------------------

    Fetching plugin "https://github.com/MBuchalik/cordova-build-architecture.git" via git clone

    Using shallow clone

    Repository "https://github.com/MBuchalik/cordova-build-architecture.git" checked out to git ref "v1.0.1" at "b787544".

    Installing "cordova-build-architecture" at "1.0.1" for android

    Subproject Path: CordovaLib

    Fetching plugin "cordova-custom-config" via npm

    Installing "cordova-custom-config" at "5.0.2" for android

    Fetching plugin "cordova-plugin-ad-admob" via npm

    Installing "cordova-plugin-ad-admob" at "1.0.118" for android

    Fetching plugin "https://github.com/cranberrygame/cordova-plugin-ad-admob-sdk" via git clone

    Using shallow clone

    Repository "https://github.com/cranberrygame/cordova-plugin-ad-admob-sdk" checked out to git ref "master" at "b22949d".

    Installing "cordova-plugin-ad-admob-sdk" at "1.0.36" for android

    Fetching plugin "https://github.com/cranberrygame/cordova-plugin-extras-google-play-services" via git clone

    Using shallow clone

    Repository "https://github.com/cranberrygame/cordova-plugin-extras-google-play-services" checked out to git ref "master" at "f6f6b28".

    Installing "cordova-plugin-extras-google-play-services" at "1.0.5" for android

    Subproject Path: CordovaLib

    Fetching plugin "cordova-plugin-inappbrowser" via npm

    Installing "cordova-plugin-inappbrowser" at "3.0.0" for android

    Fetching plugin "cordova-plugin-media" via npm

    Installing "cordova-plugin-media" at "5.0.2" for android

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Skipping 'cordova-plugin-media' for android

    Fetching plugin "cordova-plugin-statusbar" via npm

    Installing "cordova-plugin-statusbar" at "2.4.2" for android

    Fetching plugin "cordova-plugin-whitelist" via npm

    Installing "cordova-plugin-whitelist" at "1.3.3" for android

    This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.

    --------------------------------------------------------------------------------

    PROJECT PROPERTIES

    --------------------------------------------------------------------------------

    # This file is automatically generated by Android Tools.

    # Do not modify this file -- YOUR CHANGES WILL BE ERASED!

    #

    # This file must be checked in Version Control Systems.

    #

    # To customize properties used by the Ant build system edit

    # "ant.properties", and override values to adapt the script to your

    # project structure.

    #

    # To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home):

    #proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt

    # Project target.

    target=android-25

    android.library.reference.1=CordovaLib

    cordova.gradle.include.1=cordova-build-architecture/magicmotherboard-architecture.gradle

    cordova.system.library.1=com.google.android.gms:play-services-games:+

    cordova.system.library.2=com.google.android.gms:play-services-plus:+

    cordova.system.library.3=com.google.android.gms:play-services-ads:+

    --------------------------------------------------------------------------------

    COMPILE OUTPUT

    --------------------------------------------------------------------------------

    Subproject Path: CordovaLib

    The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.

    at build_do0y1jxkme7953dz5p5s9w250.run(/project/build.gradle:157)

    The JavaCompile.setDependencyCacheDir() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    Incremental java compilation is an incubating feature.

    The TaskInputs.source(Object) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use TaskInputs.file(Object).skipWhenEmpty() instead.

    The ProjectDependency.getProjectConfiguration() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    ModuleDependency.getConfiguration() has been deprecated and is scheduled to be removed in Gradle 4.0. Use ModuleDependency.getTargetConfiguration() instead.

    :preBuild UP-TO-DATE

    :preReleaseBuild UP-TO-DATE

    :checkReleaseManifest

    :preDebugBuild UP-TO-DATE

    :CordovaLib:preBuild UP-TO-DATE

    :CordovaLib:preDebugBuild UP-TO-DATE

    :CordovaLib:checkDebugManifest

    :CordovaLib:prepareDebugDependencies

    :CordovaLib:compileDebugAidl

    :CordovaLib:compileDebugNdk UP-TO-DATE

    :CordovaLib:compileLint

    :CordovaLib:copyDebugLint UP-TO-DATE

    :CordovaLib:mergeDebugShaders

    :CordovaLib:compileDebugShaders

    :CordovaLib:generateDebugAssets

    :CordovaLib:mergeDebugAssets

    :CordovaLib:mergeDebugProguardFiles

    :CordovaLib:packageDebugRenderscript UP-TO-DATE

    :CordovaLib:compileDebugRenderscript

    :CordovaLib:generateDebugResValues

    :CordovaLib:generateDebugResources

    :CordovaLib:packageDebugResources

    :CordovaLib:processDebugManifest

    :CordovaLib:generateDebugBuildConfig

    :CordovaLib:processDebugResources

    :CordovaLib:generateDebugSources

    :CordovaLib:incrementalDebugJavaCompilationSafeguard

    :CordovaLib:compileDebugJavaWithJavac

    :CordovaLib:compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    :CordovaLib:processDebugJavaRes UP-TO-DATE

    :CordovaLib:transformResourcesWithMergeJavaResForDebug

    :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug

    :CordovaLib:mergeDebugJniLibFolders

    :CordovaLib:transformNative_libsWithMergeJniLibsForDebug

    :CordovaLib:transformNative_libsWithSyncJniLibsForDebug

    :CordovaLib:bundleDebug

    :CordovaLib:preReleaseBuild UP-TO-DATE

    :CordovaLib:checkReleaseManifest

    :CordovaLib:prepareReleaseDependencies

    :CordovaLib:compileReleaseAidl

    :CordovaLib:compileReleaseNdk UP-TO-DATE

    :CordovaLib:copyReleaseLint UP-TO-DATE

    :CordovaLib:mergeReleaseShaders

    :CordovaLib:compileReleaseShaders

    :CordovaLib:generateReleaseAssets

    :CordovaLib:mergeReleaseAssets

    :CordovaLib:mergeReleaseProguardFiles

    :CordovaLib:packageReleaseRenderscript UP-TO-DATE

    :CordovaLib:compileReleaseRenderscript

    :CordovaLib:generateReleaseResValues

    :CordovaLib:generateReleaseResources

    :CordovaLib:packageReleaseResources

    :CordovaLib:processReleaseManifest

    :CordovaLib:generateReleaseBuildConfig

    :CordovaLib:processReleaseResources

    :CordovaLib:generateReleaseSources

    :CordovaLib:incrementalReleaseJavaCompilationSafeguard

    :CordovaLib:compileReleaseJavaWithJavac

    :CordovaLib:compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    :CordovaLib:processReleaseJavaRes UP-TO-DATE

    :CordovaLib:transformResourcesWithMergeJavaResForRelease

    :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForRelease

    :CordovaLib:mergeReleaseJniLibFolders

    :CordovaLib:transformNative_libsWithMergeJniLibsForRelease

    :CordovaLib:transformNative_libsWithSyncJniLibsForRelease

    :CordovaLib:bundleRelease

    :prepareAndroidArchLifecycleRuntime100Library

    :prepareComAndroidSupportCustomtabs2610Library

    :prepareComAndroidSupportSupportCompat2610Library

    :prepareComAndroidSupportSupportCoreUi2610Library

    :prepareComAndroidSupportSupportCoreUtils2610Library

    :prepareComAndroidSupportSupportFragment2610Library

    :prepareComAndroidSupportSupportMediaCompat2610Library

    :prepareComAndroidSupportSupportV42610Library

    :prepareComGoogleAndroidGmsPlayServicesAds1700Library

    :prepareComGoogleAndroidGmsPlayServicesAdsBase1700Library

    :prepareComGoogleAndroidGmsPlayServicesAdsIdentifier1600Library

    :prepareComGoogleAndroidGmsPlayServicesAdsLite1700Library

    :prepareComGoogleAndroidGmsPlayServicesAudience1600Library

    :prepareComGoogleAndroidGmsPlayServicesBase1601Library

    :prepareComGoogleAndroidGmsPlayServicesBasement1601Library

    :prepareComGoogleAndroidGmsPlayServicesDrive1600Library

    :prepareComGoogleAndroidGmsPlayServicesGames1600Library

    :prepareComGoogleAndroidGmsPlayServicesGass1700Library

    :prepareComGoogleAndroidGmsPlayServicesMeasurementBase1603Library

    :prepareComGoogleAndroidGmsPlayServicesMeasurementSdkApi1602Library

    :prepareComGoogleAndroidGmsPlayServicesPlus1600Library

    :prepareComGoogleAndroidGmsPlayServicesTasks1601Library

    :prepareProjectCordovaLibUnspecifiedReleaseLibrary

    :prepareReleaseDependencies

    :compileReleaseAidl

    :compileReleaseRenderscript

    :generateReleaseBuildConfig

    :generateReleaseResValues

    :generateReleaseResources

    :mergeReleaseResources

    :processReleaseManifest

    :processReleaseResources

    :generateReleaseSources

    :incrementalReleaseJavaCompilationSafeguard

    :compileReleaseJavaWithJavac

    :compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    /project/src/com/cranberrygame/cordova/plugin/ad/admob/AdMobOverlap.java:576: error: AdMobOverlap.MyRewardedVideoListener is not abstract and does not override abstract method onRewardedVideoCompleted() in RewardedVideoAdListener

    class MyRewardedVideoListener implements RewardedVideoAdListener {

    ^

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    1 error

    :compileReleaseJavaWithJavac FAILED

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':compileReleaseJavaWithJavac'.

    Compilation failed; see the compiler error output for details.

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 9.332 secs

    Error: /project/gradlew: Command failed with exit code 1 Error output:

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    /project/src/com/cranberrygame/cordova/plugin/ad/admob/AdMobOverlap.java:576: error: AdMobOverlap.MyRewardedVideoListener is not abstract and does not override abstract method onRewardedVideoCompleted() in RewardedVideoAdListener

    class MyRewardedVideoListener implements RewardedVideoAdListener {

    ^

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    1 error

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':compileReleaseJavaWithJavac'.

    Compilation failed; see the compiler error output for details.

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)

    at emitTwo (events.js:106:13)

    at ChildProcess.emit (events.js:191:7)

    at maybeClose (internal/child_process.js:877:16)

    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

  • It looks like you're using third-party addons. I'm afraid we cannot provide support for those. See the bug report guidelines.

  • Please, C2 community, help me with this...

    I deleted all the plugins but it's still not working! Is there NO working way to compile C2 projects anymore? This is my job, and nothing's been working, for weeks! Why does every build software keep failing after two months!

    Tell me, please, what build software works fine? Cocoon doesn't work anymore! Phonegap's not working now!... How do you use Monaca? (There are absolutely NO decent tutorials, AT ALL!)

    What do I need to change?... You can see my log... Please, tell me what to do.

    Can you please guide me to build tutorial tutorial, that actually works in October of 2018?

  • Bump.

  • On the Phonegap build website page, it says:

    App ID: 33?9???

    Version: 1.0

    Owned by: s?s?nveg@live.ca

    PhoneGap (iOS / Android / Windows): cli-6.5.0 (4.3.1 / 6.1.2 / 4.4.3)

    Source: .zip package

    Last built (43): 1 minute

    Do I need to update the cli-6.5.0 to cli-7.1.0?

    If so, how do I do that? Or is that something they can only change on their end?

  • Hi, I had this error recently.

    So I decided to take a look and scan the error log provided by PhoneGap build. I had to remove the Admob Ads plugin from my project which is a plugin featured in construct 2 itself. Upon removing the plugin the APK was compiled.

    Don't know why this is an issue but means I won't be able to run ads...

    Any issues let me know.

  • I hear you. I am new to exporting and building and I am shocked how messy it is. After several days I managed to build an app with both cocoon and phonegap, but only without adMob.

    Anyway I found this thread

    github.com/cranberrygame/cordova-plugin-ad-admob/issues/28

    So you should remove the admob plugin code and replace with:

    <plugin name="https://github.com/mukeshphulwani66/admob-fixing-cordova.git" spec="https://github.com/mukeshphulwani66/admob-fixing-cordova.git"/>

    Not sure if it works yet but the compile error disappeared!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)