The Build Failed using Intel XDK for build .APK

  • Problem Description

    I'm User Windows7 64bit sp1, I make my game construct2 R195 64bit with Node-WebKit 0.11.5, and the game works perfect.

    open the "XDK intel" version 1621, I test play in "TEST" and it works perfect. in Intel software XDK upload the project, and when I press the button to compile fails.

    screenshot here:

    https://drive.google.com/file/d/0B9uHUU ... sp=sharing

    "The build failed.

    An error occurred while building the application. Verify your build assets are correct and try again."

    Warning: Crosswalk 7 uses an insecure version of OpenSSL and may be rejected by the Google Play Store. Use Crosswalk 10 if you plan to distribute via the Google Play Store.

    how i can Update to Crosswalk 10?

    what I can do to correct this problem?

    Attach a Capx

    all .capx

    Description of Capx

    Steps to Reproduce Bug

    no apply

    Observed Result

    "The build failed.

    An error occurred while building the application. Verify your build assets are correct and try again."

    Warning: Crosswalk 7 uses an insecure version of OpenSSL and may be rejected by the Google Play Store. Use Crosswalk 10 if you plan to distribute via the Google Play Store.

    Expected Result

    compile a .apk

    Affected Browsers

    no apply

    Operating System and Service Pack

    Windows 7 sp1

    Construct 2 Version ID

    r165 64bit

  • Verify your build assets are correct and try again... what means?????

  • Please contact Intel about issues with the Intel XDK, there is not much we can do about it since it's not our build system.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • After thousands of tests, and discovered what it means: "Verify your build assets are correct and try again"

    can not be placed characters: ñ, Ñ, ·?, %, &, Etc... in the names of the sprites.

    I hope will be helpful when Build in intel XDK.

  • I still have the "Verify your build assets are correct and try again" error,

    but I have checked that all my objects and sprites don't contain ñ, Ñ, ·?, %, &, Etc....

    Is there be another source for this problem?

    This seems to be the problem in the Android Build Log:

    BUILD FAILED

    .../tools/ant/build.xml:653: The following error occurred while executing this line:

    .../tools/ant/build.xml:698: null returned: 1

    But what does this mean?

  • luisgmolina

    You need to change the crosswalk version from "stable" to "beta" or "10". If you keep "stable" it uses crosswalk version 7 (see line three of your screenshot) and that has the openSSL bug.

    apex General

    Did you try to erase the the "media" and "image" folders and export it fresh from c2? Did you try to restart intel xdk? Whenever I had that error it had been solved by doing that. Else you should open the log file, copie it to a text editor and search for "failed" or "error". There should be more information about what went wrong.

  • BUILD FAILED

    .../tools/ant/build.xml:653: The following error occurred while executing this line:

    .../tools/ant/build.xml:698: null returned: 1

    Recently i had error with this lines too, i deleted all projects in xdk and completely remove it from my pc, then downloaded latest xdk and import my game in xdk again, now everything is fine.

  • Thank you so much for the advice, the Build now works!

  • I'm getting the "The build failed. An error occurred while building the application. Verify your build assets are correct and try again." message when exporting for Android-Crosswalk. Just the above message, no other info, or option to view log. I've tried reuploading, restarting, making a new project etc. Nothing seems to work...

  • Can not be placed characters: ñ, Ñ, ·?, %, &, Etc... in the names of the sprites.

    Verify all sprites names.

    I hope will be helpful when Build in intel XDK.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)