Bug when tried to Starting Construct2 r133

  • Link to .capx file (required!):

    I don't open any .capx file

    Steps to reproduce:

    1. Just try to start construct2 r133

    Observed result:

    "Aways when I tried to start the construct2"

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    ACE table: Adding combo param with no options

    Condition: !combo_options.empty()

    File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h

    Line: 105

    Function: void __cdecl era::ACETable::AddComboParam(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,int,int)

    Build: release 133 (64-bit) checked

    Component: HTML5 exporter

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Anular   Repetir   Ignorar   

    ---------------------------

    "

    Expected result:

    Open construct2 normaly with no problems

    Browsers affected:

    Chrome: yes/no

    Firefox: yes/no

    Internet Explorer: yes/no

    Operating system & service pack:

    Windows 7 Ultimate - Service Pack 1

    Construct 2 version:

    Version r133

  • r133 works for me. Are you using any third party plugins? Does removing them fix the problem?

  • Hi Ashley, well I have some third party plugins, I will try to remove it so I will back to say if its fix the problem :)

  • Cannot reproduce here, using Windows 8 64-bit.

    I find it odd that you have a different directory structure, what is this "source"?

  • well, I have no ideas for this :(

    I removed all plugins and behaviors of third parties, but not solved :(

  • When you install the new version of C2 do you uninstall the previous version ?

  • Kyatric - yes, I always uninstall the older version, I do this usually already over 100 updates :P

    this was the first kind of this type of "bug" I found in the construct2 release

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Maybe try completely removing C2, download it and install it again ?

  • gillenew I have downloaded but not yet installed r133, can I ask, does your project still load fine with r132?...

  • well, the error is also appers when I tried to start consctruct2, so I click in the ignore option and, with 3 times tried, then construct2 opens normally (I think) :P

  • Closing as this must be a problem with third party plugins. Nobody else has reported this issue with the r133 release.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)