BUG: Error opening file keeps randomly happening

0 favourites
  • 10 posts
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • Problem Description

    Projects keep saying "Failed to open" after many hours of work. Happens randomly so I can't tell if my file will be corrupt or not whenever I save them


    Attach a Capx


    Description of Capx

    as soon as you open it, it gives the error in the image above

    Steps to Reproduce Bug

    • Step 1: Open file .

    Observed Result


    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers


    Operating System and Service Pack

    Windows 7

    Construct 2 Version ID


  • The .capx is totally corrupted and is no longer usable as it's missing a lot of it's folder structure, such as the 'Textures' folder. There is nothing anyone can do to retrieve this.

    Hopefully you'll have setup the automatic Save and Backup options.

  • how do I prevent this from happening, seems like things are being stored in the temp folder. I saved everything as a single file, so why would it be relying on external resources? The Fire.png isn't even being used in any of the code.

    also, i have backups setup, but none of them open or work. I just really need this to stop happening because I'm having to backtrack on certain days

  • Closing, it's too late, the file is already corrupt. You should keep backups or report a bug that includes the steps to cause this issue in the first place.

  • Ashley : I understand I can't recover it, thats not why I opened up the bug report. I'm trying to figure out what happened that it made it corrupt, and keeps happening randomly.

    Here's some helpful information:

    -The image in question isn't even being used in the events, and was deleted from the project, so why is it affecting it?

    -And why is my image being stored in a temp folder? I'd imagine after a computer reset, or some automated cleanup, the temp folder data would be cleared which could be causing the issue.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Rename the .capx to .zip and extract it, then you have a folder-based project. You'll need to replace all the missing files. It's only using a temp folder to extract the .capx contents to.

  • Ashley but the temp folder is where the file is missing, if that's just where it extract it, how does it go missing when it just put it there? Could the cause be something like CrapCleaner deleting temporary folder stuff?

  • Construct 2 stores your project in temp while you're editing it, so if you have some software which tries to "helpfully" clean temp while you're using the files, it will erase your project.

  • the same thing just happened to me as well;

    was working on a project and the files in the temp folder were erased, there was no error at the time, everything saved correctly and exited, when i tried opening the file again the above message appears;

    and i did have backups, actually in multiple locations, they are all giving the same error;

    I restored all the erased files from the recycle bin, but still getting an error opening the project; in fact the specific location within the appdata/local/temp folder keeps changing;

    why would this error affect the backups as well?

    sounds like a bug to me, if not then there's a problem with how the project details are being saved

    will continue to look for work arounds, would appreciate any help that anyone else has been able to come up with

  • heater19 I haven't been able to find anything either. This keeps happening though and is making it more difficult to get any progress in my file. Looks like it's getting time to swap engines for my projects for me. I just hope I can get the few projects I'm almost finished with done

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)