Blurry edges (visual annoyance)

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/23009908/construct_bugs/mrblurryedges.capx

    Steps to reproduce:

    1. Create a sprite

    2. Fill it with solid color

    3. In the editor, put sprites next to each other

    4. sprite edges look blurry.

    5. white space appears in the editor

    <img src="https://dl.dropboxusercontent.com/u/23009908/construct_bugs/mrblurryedges.png" border="0" />

    Observed result:

    Edges look blurry in editor

    Expected result:

    Edges look sharp in editor

    Browsers affected:

    Export looks fine.

    Operating system & service pack:

    win 7

    Construct 2 version:

    r132

  • I think this is side effect of the image editors "stretch" ,looking at your screenshot I can see the feathering in the image editor...

  • I updated the post.

    The sprite was created as a solid color inside C2.

  • you used the sprite object which doesn't scale when you resize to a bigger size than the original image resolution. try the 9patch.

  • Closing as not a bug. I can't reproduce a white space beside adjacent sprites at 100% zoom, although if you zoom then a normal result in computer graphics is for a seam to appear.

    Additionally, the blurry edges is a normal result in computer graphics of using 'Linear' sampling. It doesn't appear at runtime in Firefox, but you can explicitly turn it off by setting the project 'Sampling' property from 'Linear' to 'Point'.

  • you used the sprite object which doesn't scale when you resize to a bigger size than the original image resolution. try the 9patch.not resized nor scaled.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Closing as not a bug. I can't reproduce a white space beside adjacent sprites at 100% zoom, although if you zoom then a normal result in computer graphics is for a seam to appear.

    Additionally, the blurry edges is a normal result in computer graphics of using 'Linear' sampling. It doesn't appear at runtime in Firefox, but you can explicitly turn it off by setting the project 'Sampling' property from 'Linear' to 'Point'.will try point sampling then, thanks man.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)