[128] Pathfinding gets buggy when playing music

  • Link to .capx file (required!):

    dropbox.com/s/ui8ypjmlyq968qf/path%20bug%20for%20submission.capx

    Steps to reproduce:

    1. Start preview on layout 'start'

    2. Travel between layouts by moving onto the blue squares ('transitions')

    3. Explore the layouts

    Observed result:

    On the starting layout there is no problem at all (regardless of which layout it is). However, when you transfer to a new layout while playing, you'll find certain sections, particularly those with narrow passes, get buggy with pathfinding. You have to click several times or click somewhere else and re-approach the pass from a different angle.

    This only happens when music is playing. If you toggle the play music event off, it will all run as normal.

    Expected result:

    Pathfinding to work like normal

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: No (this glitch does not occur with IE, but another one does when you enter layout 'inside', where all the images go weird and cover up the screen - but that's a whole other issue I guess)

    Operating system & service pack:

    Windows 8 and don't know

    Construct 2 version:

    128 (was the same on 127)

  • Very strange, music ought to have no effect at all on pathfinding!

    I can't reproduce the problem in Firefox, only Chrome, but you said you could reproduce in Firefox. Are you sure about that?

  • Yeah I'm 100% on firefox. Actually I should note that in firefox it will have the issue even on the starting layout, where that always seems to be fine in chrome. I just tested them again in 128.2.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I just played my music files as sounds instead. Now seems to work (at the moment). In Chrome.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)