Steam Broken file association from Explorer launch

  • really nice someone is looking into this.

    I can not get it to work though (windows 7)

  • x64 bit? Try to disable UAC if enabled and install it again (as administrator).

  • Nope, no go...

    That is cool, I have the Full version of C2. It is no big deal to me, Thank you anyway.

    I am sure the Steam-only users appreciate it though.

    Really cool to see the community helping out like this.

  • U didn't provided any info (about errors or if your Windows x64 or not) so it hard to help. Try this version of my fix www4.zippyshare.com/v/91132178/file.html

  • I'm win 7 64 bit is fix better 4 64bit?

  • I'm not sure :). Script is the same but I've compiled it on newer version of AutoIt without UPX compression to avoid possible bugs.

  • okay, if script is same then that is fine.

    It's working perfectly again - thank you once again. Still don't know why it wouldn't with beta's.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • win-7 64 bit, steam 32bit, no background apps other than Steam and Desura (both are node-webkit if this is helpful).

    Script works right after install, but after I reboot, and re-launch steam, it acts as it did before.

    Running as admin did not help either. UAC has been welded OFF since 10 minutes after my first boot on this system.

    Maybe you can make a version that launches from the startup folder. Have the application uninstall, then reinstall. Maybe this will help?

  • Hmm, try this version copy.com/OUgf4qqce9JO - it should reinstall itself (in silent mode) every time Windows starts.

  • New version (fixed bug with beta's) www46.zippyshare.com/v/25117040/file.html

  • The reason opening the capx doesn't work with Steam is because the Steam version checks your account for if it owns a license. The Steam version doesn't use a license file at all so when you associate the capx file type with te executable, it opens the project but doesn't go through steam meaning it can't check your account for ownership. I don't think this is really fixable by Scirra unless they change the Steam version to also use the license file.

  • Hmm the fix only opens Construct 2 for me and starts the open file dialog.

    So I've created my own bugfix.

    What you need:

    autohotkey.com (free macro program)

    After you've installed authotkey:

    • rightclick in explorer -> new -> autohotkey script
    • name it how you want, remember the file location (for me it is D:\Games\Steam\construct2.ahk)
    • rightclick on the script, edit the script

    paste the following below the default first lines:

    <font color=blue><font face="Arial, Helvetica, sans-serif">IfWinNotExist, Construct 2

    {

    run, steam://rungameid/227980

    WinWait Construct 2,, 120

    }

    WinActivate Construct 2

    WinWaitActive Construct 2

    sleep 1000

    send ^o

    sleep 400

    send %1%

    send {Enter}</font></font>

    • save it
    • open a text editor of your choice (like notepad)

    pase the following

    <font color=blue><font face="Arial, Helvetica, sans-serif">"D:\Games\Steam\construct2.ahk" %1</font></font>

    Note that D:\Games\Steam\construct2.ahk needs to be the location of your autohotkey script I told you to remember earlier.

    -Save it as something like construct2.bat

    • next time you want to open a .capx or .caproj, select "open with" and use the construct2.bat you've created.

    What it does:

    If Construct 2 is not open yet, it runs steam://rungameid/227980 (it is the command for steam to launch construct 2, you can find that out when you create a shortcut of the program on the desktop via steam). It waits at most 120 seconds for the Construct 2 to start.

    After that it sets the Construct 2 window as active (in foreground), opens the "open file" dialog, pastes the file location into the field and confirms it. If it is not working as expected for you, try to adjust the sleep lenghts.

    Hope it helps if someone wanted to do something like that for himself.

    If you want icons for your .capx-files in the explorer, look up Bat To Exe Converter and convert/compile the .bat into an .exe-file and set the icon file to one of those in the Construct 2 directory.

  • Thanks, looks good. However I gave up and purchased business license here, was the best feeling uninstalling the steam version.

    Seriously, I went from multiple crashes every couple hours to ZERO issues since I moved away from steam version.

    Best money spent... seriously.

  • mindfaQ

    What Windows version does you have? UAC on or off?

    Your fix doesn't differ much from mine. But alternatives is always good.

    Maybe I'll make an installer (like I've made for mine) for it if somebody asks.

  • I just noticed my error, used c2_fix exe instead of start.bat. Sorry for the commotion ^^. Works like a charm as well.

    edit: no, it doesn't (I tested it on another pc where it worked, but now back to the first PC it is still not working even when I use start.bat)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)