[NWJS v0.20.0] Touch doesn't work well, far from well.

0 favourites
  • 5 posts
From the Asset Store
20 high-quality 2D monsters. This asset is perfect for a side scrolling game, or even a turn based RPG type game.
  • Problem Description

    This is the NWjs for C2. I downloaded it from here : NWJs for C2 https://www.scirra.com/nwjs

    v0.20.0 (Chromium 56) [Requires r217+]

    [NWJS v0.20.0] Touch doesn't work well, far from well. I have a .capx below that shows it. I have installed the latest version for a long time now but I just tried to preview my project now.

    I have noticed that in every update of NWjs, the touch is getting more and more unusual but I didn't mind (I thought at first that it was my ultrabook that was at fault but my touch is working fine on chrome so it wasn't. My ultrabook's touch screen is still working fine.) until the latest version of NWJS.

    +This is only isolated to NWjs since Chrome's touch is still working fine.

    Attach a Capx


    Description of Capx

    It's a touch dragging test.

    Steps to Reproduce Bug

    • Touch Drag the black squares.
    • Then Touch Drag the black squares simultaneously. There are 10 black squares for further analysis using your 10 Multi-touch points.
    • Notice the effects.

    Observed Result

    Single Touch Drag: The Black Squares are dragged initially but stops getting dragged afterwards.

    Multi-Touch Drag: Other Black Squares fail to be dragged. The Single Black Square is only dragged initially but stops getting dragged afterwards.

    Expected Result

    Touch on NWjs for C2 to work properly like on Chrome.

    Affected Browsers

    • NWjs: Yes

    Operating System and Service Pack

    Windows 8.1 64-bit

    v0.20.0 (Chromium 56) [Requires r217+]

    Construct 2 Version ID

    Construct 2 r243 Beta Release

  • Tried NWJS last week and noticed that touch did not work (works everywhere else).

    Assumed it was something I was doing wrong as fist time trying NWJS.

    I will verify tonight....

  • I tried, tonight , your capx above and my game on my Surface.

    On nwjs preview

    the touch dosent work.

    However on njws export its ok.

    So something going wrong in preview mode.....

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Is NW.js v0.21.1 (based on Chrome 57) affected?

  • Ashley

    Sorry for the very late response.

    Ive just tried with v0.22.0 (Chromium 58)

    No change as far as I can see.

    Previewing nw.js from C2 (edit r244) touch is still playing up, sticking, unresponsive, laggy.

    Exported nw.js though is fine.

    This is on windows 10 surface pro 4

    edit: just analysed whats going on, maybe might help

    On Preview it seems to register the correct touch input for a fraction of a second then totally ignores further input until all touch off then it resets and will recognize the next touch input again but just for a fraction of a second only again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)