Multiplayer Function

0 favourites
  • 5 posts
From the Asset Store
The official Scirra Multiplayer Signalling Server for helping peers find and connect to each other
  • Problem Description

    It seems that using Multiplayer peer states for number comparisons seems to cause an error.

    I also tried turning them into local variables first, which resulted in the same problem.

    This happened to me in preview mode. (Using LAN preview)

    Description of Capx

    It's an altered version of the Multiplayer game example.

    I only changed the game name global variable and added groups of events under "Host" and "Peer", which are called "Bug Testing Host" and "Bug Testing Peer"

    Capx Link ... PKq_PDmY0G

    Steps to Reproduce Bug

    • Have a peer send an input state
    • Use the input state in a comparison (such as "Compare two values")

    Observed Result

    After the error appears the event that seemingly caused it couldn't fire, causing the the player not to move to the X100 coordinate.

    Expected Result

    The peer should move to the X coordinate it sends while holding RMB, which is 100.

    Affected Browsers

    • FireFox: (YES) (V. 60.0 64Bit)
    • Others not tested

    Operating System and Service Pack

    Windows 7 Enterprise 64bit Service Pack 1

    Construct 2 Version ID

    Beta r258 64bit on Windows

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • After the error appears

    What error is that? What exactly are you seeing? Please be as specific as possible, otherwise it's difficult to investigate reports.

  • Oh yes, I forgot to copy the error message in here. Sorry about that, I wrote that post right before going to bed after trying to find what causes it.

    Here it is:

    Assertion failure: Calling expvalue.set_float without number type

    Stack trace:
















    Subsequent failures will now be logged to the console.

  • The issue has been solved.

    I forgot to add the corresponding client input value tags. My bad.

    Sorry for the false report.

  • It's still a bug. It should at least return an empty value rather than show that error.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)