Cannot type "@" in properties

  • Problem Description

    When I want to type "@" sign in email property, I can't. It pastes content from clipboard instead of I have Slovenian keyboard. For typing "@", I have to press AltGr and V (or Ctrl+Alt+V), but it doesn't work.

    There are workarounds (Copy from somewhere and paste it, hold Alt and type 64), but anyway, I think it's a bug.

    I can't type in any Property.

    Attach a Capx

    No Capx required since it's an editor bug.

    Description of Capx

    /

    Steps to Reproduce Bug

    • Step 1: Open Construct 2
    • Step 2: Create a new project (or open an existing one)
    • Step 3: Click in email (or any other) property
    • Step 3: Try to type "@" (AltGr + V)

    Observed Result

    Content from clipboard pastes.

    Expected Result

    Sign "@" should appear.

    Affected Browsers

    • /

    Operating System and Service Pack

    Windows 8.1 64-bit

    Windows XP SP3 32-bit

    Windows 7 SP1

    Construct 2 Version ID

    r193 (Beta)

    r192 (Beta)

    And probably previous releases too.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Can't reproduce, works just fine here with a UK keyboard. Are you sure it's not a problem specific to your system?

  • No problem here, also.

  • Hey, Ashley

    I'm sure it's not in my system ... I've tried on 2 different computers, with different OS ... It looks like it's only with Slovenian keyboard ... On other places in C2 (event sheets), I can type in I can't it only in properties.

    Also, if I press Shift and 2 (I think that's on English keyboards), the " sign appears (like on Slovenian keyboard).

    I'll try on yet another computer tomorrow.

  • Hey there,

    now I've tried on another computer, and the problem is there, too.

    I've tried to change keyboard to US - and it works then if I press Shift and 2. But I'm using Slovenian keyboard, where you have to press Alt Gr and V to get Could you please try to set to Slovenian keyboard if you can't reproduce the problem?

  • Hey, Ashley

    I've just tried other AltGr signs (\€÷×{}¤ ...), and they appear normally. Only doesn't appear.

    • (AltGr) + (Q)
    • (Strg) + (Alt) + (Q)

    Both correctly working using Austrian keyboard layout.

  • Hold down "Alt", type "64", then release "Alt".

    keycodes

  • Hold down "Alt", type "64", then release "Alt".

    keycodes

    Yes, yes, thank you. But that's a workaround... AltGr + V is probably here just for faster way to type ... I can type it in event sheets. But not in properties.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)