How do I stop jump direction change in mid air?

0 favourites
  • 3 posts
From the Asset Store
Rotate & Animation for 16 Direction & Mouse Direction
  • Hello,

    I have a character that has the platform behavior and I also provide the player with alternate controls using WASD (default controls still enabled to have both controls and reduce number of actions).

    My problem is as follows, I'd like to stop the player from changing their direction of jump after jumping. I think a perfect case of this is in Castlevania. I tried the actions:

    On Jump -- Disable Controls

    On Floor -- Enable Controls.

    However that ends up with the player jumping in place and not anything else. I tried it with a boolean such as below:

    On Jump -- Set Bool to true

    Bool true -- Disable Controls.

    ON jump (inverted) -- Set Bool to False.

    But that doesn't work. It works for like a second and then it stops all controls. Is there any quick way to fix this, please?

    Thank you very much in advance.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • On air try to set acceleration and decceleration to 0, then restore it back to normal when on ground

  • Ahh, I knew it was simpler than the disable controls. Thank you very much!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)