Simulate jump not functioning

  • Simulate jump doesnt fire when it reaches activemode2 the numbers work on the debug mode and ive tried multiple ways of firing the jump however the shift to jump animation works as well as the shift to falling animation i get the feeling it might be a construct 2 inside code glitch as ive had many of those before that disallow the properties to function when fired in a very specific order

    imgur.com/f40RuLr

  • Add debug output to your event 109, for example:

    Browser -> Log "Boss Jumping"

    Then open console (F12) in your browser and check if it's triggered.

    If it is, but the boss is still not jumping, my guess is that when you change animation to "Jump", the collision polygon appears above the ground, so the platform can't perform the jump.

    Try changing animation after "Simulate jump" action.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It was in fact the shift in the animation putting it into the floor a simple .01 wait did the trick thank you good sir

  • I recommend you check collision polygons for all frames in all animations - ideally they should be identical. And Origin image point should always be in the center. This will save you lots of troubles.

    Many people use this trick - add an invisible sprite with just one frame and platform behavior, name it BossPlatform. Remove platform behavior from Boss sprite. Pin Boss to BossPlatform.

    You will be able to control BossPlatform, and animations/polygons on Boss sprites will not interfere will platform movements.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)