Multiplayer: works in LAN only...

0 favourites
From the Asset Store
The official Scirra Multiplayer Signalling Server for helping peers find and connect to each other
  • *sorry for my English*

    Hi, I'm following the multiplayer real-time game project: my game works well under the same connection, but with different connections the peer will be kicked.

    I've not a good English, so maybe i didn't understand something...

    what could generate this problem?

    Can someone help me please? thanks!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm not sure if this helps at all but,

    but do you have a dynamic ip or static ip?

    A few months ago I tried hosting some games and people could not connect to me for some reason, so I read somewhere that having a static ip and port forwarding would help with this.

    I'm not sure if this will help but, maybe you can look into it.

    Also have you tried running the game on different computers? Different host to different players connecting?

  • Yes, I tried on several devices. Always the second device try to connect, but at the least, it will be kicked..

    Maybe I need a dedicate app for host?

    I'm really locked, I don't know what to do..

  • So no one can help me??

    Ashley Can I send my capx to you?

  • It depends on your network configuration, particularly the NAT setup. It's not really anything to do with the .capx.

  • Ashley Thanks for reply.

    My game is based on your example. Your works well, mine not.

    I tried to upload the project on a website, but same error. ->

    Why your example works and mine not?

  • Ok, I think I need to set up something here. Am I right??

  • I've got the same problem. Multiplayer only works at my local network. Not when someone else tries to connect to the game from the Internet.

    I bypassed my router and connected my computer directly to the network but that did not help. I also disabled my software firewall for a moment, same result, not working.

    I've uploaded the Chat example to the Scirra Arcade Tutorial games. Does it work if other people try it?

    The strange thing is that I've tried the chat example and also the multiplayer game example with my friend a few months ago and it did work. I exported it as a HTML5 and send it to my friend as a zip package.

  • It seems to work... Must be something with the NAT then. Too bad. It's almost impossible to test and develop my game because of this problem.

  • Found this:

    I think can solve this problem, but I don't tried it, so I don't know how it works.

    If you try it, let me know something please!

  • I'm going to try this Photon Cloud plugin

  • But you need to pay and to change several events in your project!

  • Yes you're right...

    So, I think I have to reconsider what I'm going to do with my game. I tried the multiplayer option because I noticed that it's not easy to create convincing AI opponents. I thought that I make it multiplayer so I don't have to figure out how to improve the AI but unfortunately there are connectivity issues.

  • I'm continuing to create my game, but I don't understand why Ashley always says your NAT, while his tutorial works FINE with MY NAT.

    I'm loosing my time? Or maybe am I really stupid to don't uderstand?

  • I think that many of us are waste our time with Multiplayer feature of Construct 2.

    I have read lots of comments from other developers and the answers of Ashley and I haven't seen just one answer with proper solution. I can conclude that using of Multiplayer object is not feasible since you can not release a multiplayer game working only in a LAN network.

    I've struggled a lot with this Multiplayer feature and it only works properly in a LAN Network.

    I would like to have only one reason regarding this feature to keep using my bought license of Construct2. I think that is not bad platform at all but it has serious restrictions and I don't know exactly if the cause comes from the Scirra Support or the product itself.

    The developers need an urgent solution for this and please, don't attribute the problem to network configurations since we have tested many many different configurations and none of them works properly (except for LAN network).

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)