How do I keep double jumping from being disabled

  • I have the following events for being able to double jump while overlapping the water sprite. It works perfectly fine except for when I set the playerbox scale to anything lower than '1'. After that it will work sometimes but not always.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If you have a smaller scale, then your object may not be overlapping. And as such the code wouldn't work.

    Why would you want to change the collision box's scale ? Prefer to modify its size directly.

  • Thanks! I fixed it by blanketing the body of water with one invisible sprite that the player can overlap with to change its settings. The water sprites were all separate and snapped to the grid. When the scale was changed on the player it must have been somehow not been overlapping between water sprites even though there was no open space between them.

    I tried changing the size of the 'playerbox' in the above eventsheet and the appropriate player sprite at first. Once the player sprite was smaller than the original 16x16 it would no longer become mirrored when moving to the left, it would always stay facing one direction.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)