Gamepad not working properly?

0 favourites
  • 7 posts
From the Asset Store
Total customisation of the input! You can combine inputs from all peripherals. Make your game accessible for everyone!
  • I currently have my players dash when the player holds the R trigger, then either pushes the right joystick to the left or right. The idea is very similar to that of Super Smash Bros.

    The problem is that I'd like to have the player be able to jump (L trigger) while dashing, but this only works when I dash and immediately let go of the R trigger. Why is it that I can't jump while I'm holding the R trigger? The player is able to jump when I have any other button, so is there something is causing the triggers to not be read while both are down?

    Anybody have ideas about this? I've tried a bunch of different events, but I just can't seem to figure it out.

  • You should post your capx, that would make it easier to investigate and see if there is something wrong with your events or with the gamepad integration/support.

  • Thank you for the reply, sorry about that. Here is an example of what I have. Keep in mind that this is just a new project with one event, but it's essentially how I had my other game set up.

    The way it is now, I can hold any button down except for the R trigger and still jump. Another thing that I noticed is that if I hold down L trigger ( which is the button to jump) and then press the R trigger (not binded to anything) he will jump for some reason.

    Edit: Is this possibly a bug or just something I can correct within the event sheet?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've just tried with my Xbox 360 controller, on chrome, and I can't replicate the issue you are talking about.

    With only this event in the project, holding down the right trigger doesn't seem to have any impact on the left one.

    You should post your complete capx (either attach it to the post, or on dropbox or service of the like) and post what controller you use, in what browser on what OS.

  • Ahhhh dang haha! I see, I completely forgot that I had upgraded to the new beta for Firefox and switched to that, instead of keeping chrome as my default browser. But you are right, I wasn't able to replicate the issue on chrome either, just on Firefox beta. Do other versions of Firefox support gamepads? I believe I'm having the blacklist issue on chrome, so it's always stuck on Canvas2D, which is why I wanted to try the beta for Firefox.

    Thanks for your help by the way!

  • Firefox does not support gamepads, but the next version (v29) is noted as supporting it. It should work in Nightly already if you have that.

  • It works perfect on Chrome, but I've tried both v29 Beta and the latest Nightly with both of them encountering the same gamepad issue.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)